The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 05-27-2020, 06:07 PM
Madrivi Madrivi is offline
Registered User
 
Join Date: May 2020
Posts: 3
POST ID # = 1048183
Madrivi Reputation: 10
Default Help with some info about RM850i

Hi, i have bought an RM850i psu, and just unboxed it.

Before installing the psu i wanted to test it, i plugged the AC cord and did the test fan, all ok, it spins.

My questions are:

With only the AC cord connected, the little Led in the test are, has to work? Mine in off, no light...is it broken?

My other question is about the psu version, my psu has a black box with yellow details, and the date im the box is 2016. Is an old PSU? There are newer versions of the RM850i? No revision since 2016?

Thanks!
Reply With Quote


  #2  
Old 05-27-2020, 08:26 PM
jonnyguru jonnyguru is offline
PSU GUY
jonnyguru's PC Specs
 
Join Date: Feb 2003
Posts: 3,142
POST ID # = 1048196
jonnyguru jonnyguru Reputation: 179
Send a message via ICQ to jonnyguru Send a message via MSN to jonnyguru Send a message via Yahoo to jonnyguru Send a message via Skype™ to jonnyguru
Default

This is the most current RM850i box:



Is yours different?

Where are you seeing 2016? The date code for the PSU or the copy-write date for the box art?

The LED will not do anything until plugged into a motherboard.
Attached Images
File Type: jpg corsair_rm850i_psu.jpg (90.7 KB, 78 views)
Reply With Quote


  #3  
Old 05-28-2020, 03:31 AM
Madrivi Madrivi is offline
Registered User
 
Join Date: May 2020
Posts: 3
POST ID # = 1048226
Madrivi Reputation: 10
Default

Hi, thanks for your reply, yes, that's my box, the date was in the copyright as you say, and the psu was not connected to the motherboard, so all seems to be fine, thanks for helping!

One last question, the RM850i is the same as the RM850 but with Corsair Link?
Reply With Quote


  #4  
Old 05-28-2020, 04:01 PM
jonnyguru jonnyguru is offline
PSU GUY
jonnyguru's PC Specs
 
Join Date: Feb 2003
Posts: 3,142
POST ID # = 1048332
jonnyguru jonnyguru Reputation: 179
Send a message via ICQ to jonnyguru Send a message via MSN to jonnyguru Send a message via Yahoo to jonnyguru Send a message via Skype™ to jonnyguru
Default

Quote:
Originally Posted by Madrivi View Post
Hi, thanks for your reply, yes, that's my box, the date was in the copyright as you say, and the psu was not connected to the motherboard, so all seems to be fine, thanks for helping!

One last question, the RM850i is the same as the RM850 but with Corsair Link?
No. It's the same as the RM850x, but with Corsair Link and an FDB fan (as opposed to rifle bearing).
Reply With Quote


  #5  
Old 06-03-2020, 09:58 AM
Madrivi Madrivi is offline
Registered User
 
Join Date: May 2020
Posts: 3
POST ID # = 1049055
Madrivi Reputation: 10
Default

Thank you for your help, the PSU is installed and all its working superB.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.