The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Memory

Notices

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-27-2020, 02:24 PM
SpokaneVan SpokaneVan is offline
Registered User
SpokaneVan's PC Specs
 
Join Date: Jan 2020
Posts: 1
POST ID # = 1033001
SpokaneVan Reputation: 10
Default CMK32GX4M2K3600C16 on ASRock x570 Steel Legend?

Hello All,

I have the CMK32GX4M2K3600C16 (VENGEANCE® LPX 32GB (2 x 16GB) DDR4 DRAM 3600MHz C16 Memory Kit) that I assumed would work on the ASRock x570 Steel Legend mobo since DDR4 is a standard. I can't even get the system to POST, and the system status LEDs on the board have CPU/DRAM lit up. I have a suspicion that the RAM may not be working in the board. Has anyone been able to get this particular RAM kit working in an ASRock x570-based board before? The product description only says Intel 300 series, but I had assumed that DDR4 as a standard means it would work (even if it only POSTed at non-XMP speed).
Reply With Quote


 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.