The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-15-2015, 08:25 PM
CoalRage CoalRage is offline
Registered User
 
Join Date: Oct 2015
Posts: 1
POST ID # = 814522
CoalRage Reputation: 10
Default Corsair Void Wireless no longer turning on or recognised by Windows after Firmware 33

Hi

I updated the firmware on the void wireless to 33, it said it has completed successfully. After trying to turn the headset on it would not do anything. Had a look on here to see if anything could be done, have tried to pair it several times as suggested, but as the headset won't turn on or do anything it cannot be paired. With the USB cable plugged in Windows labels it as "Unknown USB Device (Invalid Device Descriptor). Can someone please tell me how to fix this if it is possible.

Thanks
Reply With Quote


  #2  
Old 10-19-2015, 01:46 PM
Corsair Chris Corsair Chris is offline
Corsair Employee
 
Join Date: Mar 2014
Posts: 381
POST ID # = 815224
Corsair Chris Reputation: 10
Default

If it doesn't turn on or do anything, it may be in bootloader mode. Follow the instructions in the sticky thread.
Reply With Quote


  #3  
Old 10-21-2015, 05:38 PM
gcarr gcarr is offline
Registered User
 
Join Date: Oct 2015
Posts: 1
POST ID # = 815648
gcarr Reputation: 10
Default

I had the same issue and after no help from Corsair i figured out how to fix the yellow jacket version i removed the dongle and pluged my headset charge directly to the dongle cradle then the dongle to another usb directly and then turned the unit on till it had green lights on the mic and the cue software updated the firm ware to the headset and fixed the issue hope this helps
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.