The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Notices

Closed Thread
 
Thread Tools Search this Thread Rating: Thread Rating: 50 votes, 4.82 average. Display Modes
  #61  
Old 03-27-2015, 10:40 PM
mittelk mittelk is offline
Registered User
mittelk's PC Specs
 
Join Date: Feb 2014
Posts: 35
POST ID # = 769126
mittelk Reputation: 12
Default

Quote:
Originally Posted by jreid360 View Post
I have been waiting patiently as well. I have 2 H80i’s and 1 H100i. I have not returned either as I have been hoping for a stable Link Software release for 2 years now. I have continued to buy the “I” series because I see the potential of the software.

Negative comments aside. This comes down to a process of marketing and advertising your hardware specifically with Link Software compatibility on windows 7 and windows 8 platforms. The Link Software gives your products a seeming “step up” on the competition. The ability to monitor Link marketed hardware with the Link Software. Corsair has confirmed in this thread the ability of the software has fallen short on that advertisement.

If Corsair isn't careful this has all the makings of turning into a class action lawsuit where they could stand to lose millions vs investing a few hundred thousand dollars in a competent/devoted development team.

Think about it… You are already losing hundreds of thousands if not Millions in Direct RMA’s, Reverse Logistics, Support Staff Headcount and Customers Returning the products to vendors because they get the product home and find it doesn’t work as advertised. That is a major let down as a consumer. (It was for me.) In theory, your software related returns on “I” series hardware could potentially range 30%-70%. Meaning the hardware works great but the software doesn’t and causes the consumer to return the non-defective hardware. The average consumer would think that the software is necessary/required to properly run the hardware (eg. the fans of the H100i or H80i).

Corsair – Please save yourself money in agonizing court procedures and do what you set out to do. Give us the innovating hardware and software combo you set out to create and that we set out to purchase. It’s not as difficult as you are making it. All of this unnecessary delay is only wasting millions in potential revenue. It’s really ridiculous when you think about it.
That's an idea, I bought the cooler with the idea that I would have good software to control and monitor my system. It's been a FAIL, and there doesn't seem to be any word on if anything is coming. This is making me decide that I'll go elsewhere for coolers. they said a couple weeks, that's come and gone. I'm very disappointed in Corsair, poor customer service on this.

Last edited by Technobeard; 03-29-2015 at 11:42 PM. Reason: added ] to fix the BBCODE for the quote


1 members found this post helpful.
  #62  
Old 03-29-2015, 05:49 PM
WhiteSnake76's Avatar
WhiteSnake76 WhiteSnake76 is offline
Registered User
WhiteSnake76's PC Specs
 
Join Date: Dec 2014
Location: Netherlands
Posts: 13
POST ID # = 769368
WhiteSnake76 Reputation: 10
Default

Yeah, i bought the HX750i PSU mainly for the Corsair Link monitoring software... and it does not work... so i really feel i wasted my money on it and should have gone with a cheaper powersuply.
Seeing how long this has been going on and theres still no fix i think Corsair is seriously letting customers down.

They should have first made sure the Corsair Link software worked fine before releasing Corsair Link products, not the other way around...


  #63  
Old 03-30-2015, 11:50 AM
felipy2k felipy2k is offline
Registered User
felipy2k's PC Specs
 
Join Date: Jan 2009
Posts: 19
POST ID # = 769490
felipy2k Reputation: 10
Default

Quote:
Originally Posted by WhiteSnake76 View Post
Yeah, i bought the HX750i PSU mainly for the Corsair Link monitoring software... and it does not work... so i really feel i wasted my money on it and should have gone with a cheaper powersuply.
Seeing how long this has been going on and theres still no fix i think Corsair is seriously letting customers down.

They should have first made sure the Corsair Link software worked fine before releasing Corsair Link products, not the other way around...
agreed ! .... i will think twice b4 buy anything from Corsair again!


  #64  
Old 03-30-2015, 12:38 PM
Georgsen Georgsen is offline
Registered User
 
Join Date: Mar 2015
Posts: 9
POST ID # = 769502
Georgsen Reputation: 10
Default

Quote:
Originally Posted by WhiteSnake76 View Post
Yeah, i bought the HX750i PSU mainly for the Corsair Link monitoring software... and it does not work... so i really feel i wasted my money on it and should have gone with a cheaper powersuply.
Seeing how long this has been going on and theres still no fix i think Corsair is seriously letting customers down.

They should have first made sure the Corsair Link software worked fine before releasing Corsair Link products, not the other way around...
Same here. I bought the H100i and it was a mess. Worked it out by downgrading the SW. Had some problems with 2x CX750M, and Corsair fixed that for me, but while waiting i bought a AX860i, and the readings i get is not to be trusted in any way.
Unless the readings are right, if so is, my AX860i is awesome since it more than often is more than 100% efficient! (yeah, I know that is not posible...)


  #65  
Old 03-30-2015, 04:51 PM
mittelk mittelk is offline
Registered User
mittelk's PC Specs
 
Join Date: Feb 2014
Posts: 35
POST ID # = 769559
mittelk Reputation: 12
Default

Quote:
Originally Posted by Georgsen View Post
Same here. I bought the H100i and it was a mess. Worked it out by downgrading the SW. Had some problems with 2x CX750M, and Corsair fixed that for me, but while waiting i bought a AX860i, and the readings i get is not to be trusted in any way.
Unless the readings are right, if so is, my AX860i is awesome since it more than often is more than 100% efficient! (yeah, I know that is not posible...)
My AX860i is a fantastic unit, it handles my x99 system and 2 R9-290X cards wonderfully but the fly in the ointment is CorsairLink software. Since my Windows 8.1 upgrade it's been a failure and I am not one that blames Win 8.1 for everything, I've had no issues with it as an OS. I'm left here wondering what Windows 10 will bring as far as CorsairLink goes but my problems with it has shown me that it's time to move on elsewhere. Pity, the hardware is fine, probably stick to memory and psu's but there are coolers out that work just as well with less software headaches. This thread was started to provide updates, haven't seen any. Where????????????????


  #66  
Old 03-30-2015, 05:59 PM
swarfega's Avatar
swarfega swarfega is offline
Registered User
swarfega's PC Specs
 
Join Date: Oct 2014
Posts: 107
POST ID # = 769571
swarfega Reputation: 13
Default

Quote:
Originally Posted by mittelk View Post
My AX860i is a fantastic unit, it handles my x99 system and 2 R9-290X cards wonderfully but the fly in the ointment is CorsairLink software. Since my Windows 8.1 upgrade it's been a failure and I am not one that blames Win 8.1 for everything, I've had no issues with it as an OS. I'm left here wondering what Windows 10 will bring as far as CorsairLink goes but my problems with it has shown me that it's time to move on elsewhere. Pity, the hardware is fine, probably stick to memory and psu's but there are coolers out that work just as well with less software headaches. This thread was started to provide updates, haven't seen any. Where????????????????

Sorry to disappoint but its the same story with Windows 10 10041 build. Pump and fans aren't detected for me so I am unable to set fan configs or to change the color of the lighting.


  #67  
Old 03-31-2015, 07:03 AM
ApexAU ApexAU is offline
Registered User
ApexAU's PC Specs
 
Join Date: Jan 2015
Posts: 78
POST ID # = 769632
ApexAU Reputation: 13
Default

James and others, is there any news you can share about Link? I'm still patiently waiting for the overhauled version...


  #68  
Old 04-12-2015, 03:02 AM
Dracius Dracius is offline
Registered User
Dracius's PC Specs
 
Join Date: Mar 2015
Posts: 8
POST ID # = 772223
Dracius Reputation: 10
Default

Any update about an update? :(


  #69  
Old 04-12-2015, 12:11 PM
mittelk mittelk is offline
Registered User
mittelk's PC Specs
 
Join Date: Feb 2014
Posts: 35
POST ID # = 772284
mittelk Reputation: 12
Default

Quote:
Originally Posted by swarfega View Post
Sorry to disappoint but its the same story with Windows 10 10041 build. Pump and fans aren't detected for me so I am unable to set fan configs or to change the color of the lighting.
Not really a disappointment just no surprise that it is, however Win 10 is still in developement so it's kind of early to say it's a fail there but I'm not really holding my breath. Shame, the hardware is just fine, software is the weak point.


  #70  
Old 04-15-2015, 07:20 PM
LoWRiDeR82 LoWRiDeR82 is offline
Registered User
LoWRiDeR82's PC Specs
 
Join Date: Nov 2013
Posts: 20
POST ID # = 772911
LoWRiDeR82 Reputation: 10
Default

Hello, any updated WORKING version of corsair link?

I have a new z97 rig with i7 4790k and the link software is junk. It keeps malfunctioning. I can hear the USB disconnect sound all the time as if I unplugged something (which I have not) and this happens only when I install corsair link so it is not a hardware issue.

This is unacceptable. FIX IT CORSAIR!


  #71  
Old 04-16-2015, 04:28 PM
fabio84's Avatar
fabio84 fabio84 is offline
Registered User
 
Join Date: Apr 2015
Posts: 2
POST ID # = 773094
fabio84 Reputation: 10
Default

I have a problem with corsair usb h100i gtx ringing all the time and can not manage the fan and pump speed !!!!

when has an update that works for windows 7 , 8.1, 10 ?


  #72  
Old 04-17-2015, 12:26 PM
CircuitWizardry CircuitWizardry is offline
Registered User
 
Join Date: Jun 2014
Posts: 107
POST ID # = 773238
CircuitWizardry Reputation: 21
Default

Cool Guy,

The last update we were given was 2/11. It has been 60 days, without any official update. It seemed you came here to provide some support. If you really wish to do so, I think an update every 2 weeks, that would take you less than 5 minutes of time, seems reasonable. You are losing credibility here every day you fail to provide an update.

The ball is in your court, and right now the lack of any update on progress is speaking very loudly.


  #73  
Old 04-18-2015, 09:37 AM
LoWRiDeR82 LoWRiDeR82 is offline
Registered User
LoWRiDeR82's PC Specs
 
Join Date: Nov 2013
Posts: 20
POST ID # = 773447
LoWRiDeR82 Reputation: 10
Default

Quote:
Originally Posted by CircuitWizardry View Post
Cool Guy,

The last update we were given was 2/11. It has been 60 days, without any official update. It seemed you came here to provide some support. If you really wish to do so, I think an update every 2 weeks, that would take you less than 5 minutes of time, seems reasonable. You are losing credibility here every day you fail to provide an update.

The ball is in your court, and right now the lack of any update on progress is speaking very loudly.
Agree..I was a Corsair fan..from case (obsidian 650d) to watercooling (H100i) to PSU.

I'm switching to NXZT case/cooler/cooling control. Had enough with Corsair. They are completely unprofessional.


  #74  
Old 04-19-2015, 06:58 AM
sparkymatt sparkymatt is offline
Registered User
sparkymatt's PC Specs
 
Join Date: Apr 2015
Posts: 5
POST ID # = 773567
sparkymatt Reputation: 10
Default

Quote:
Originally Posted by swarfega View Post
Sorry to disappoint but its the same story with Windows 10 10041 build. Pump and fans aren't detected for me so I am unable to set fan configs or to change the color of the lighting.
I have updated to Windows 10 10049 build and now Corsair Link fails to run at all, saying there is a compatibility issue. I have tried running in Windows 7 and Windows 8 compatibility mode, but still fails to start.

What has changed that now stops Link from working, and will this be fixed in a later Link build?

Matt


  #75  
Old 04-20-2015, 08:32 PM
iksaar's Avatar
iksaar iksaar is offline
Registered User
iksaar's PC Specs
 
Join Date: Nov 2014
Location: france
Posts: 9
POST ID # = 773823
iksaar Reputation: 10
Default

Quote:
Originally Posted by sparkymatt View Post
I have updated to Windows 10 10049 build and now Corsair Link fails to run at all, saying there is a compatibility issue. I have tried running in Windows 7 and Windows 8 compatibility mode, but still fails to start.

What has changed that now stops Link from working, and will this be fixed in a later Link build?

Matt
Same thing for me


Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.