The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 03-26-2012, 03:52 PM
PocketChange PocketChange is offline
Registered User
 
Join Date: Mar 2012
Posts: 2
POST ID # = 569161
PocketChange Reputation: 10
Exclamation Corsair SP2500 Problem?

Hey everyone, so basically I have had my speakers for two days now. And I have not stopped using them, I love them to death. For some reason I was listening to them and the right speaker stopped working all of a sudden. Like dead in the middle of the song. I tried plugging the speaker into the other one's (Left Speaker) cable and it worked perfectly fine, so it seems to be the cord in the second speaker (Right speaker) that is the problem. A day passed and they both work out of the blue now so I am not to sure what the problem is or what it was or if it is fixed or if I should make use of that warranty, please help!!! The right speaker just stopped working again right now!! Someone please help!

Last edited by PocketChange; 03-26-2012 at 06:45 PM.
Reply With Quote


  #2  
Old 04-03-2012, 07:39 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,268
POST ID # = 570555
RAM GUY Reputation: 10
Default

Sorry for the late reply but if I understand you correctly you can play with the cables and they will work normally is that correct? If so please use the link on the left and request an RMA and we will be happy to sent you a new set of cables. Please let me know the case number and I will see it gets done ASAP.
__________________
Support accounts and tickets can be created at https://support.corsair.com.
Reply With Quote


  #3  
Old 04-04-2012, 09:12 PM
PocketChange PocketChange is offline
Registered User
 
Join Date: Mar 2012
Posts: 2
POST ID # = 570772
PocketChange Reputation: 10
Default

Quote:
Originally Posted by RAM GUY View Post
Sorry for the late reply but if I understand you correctly you can play with the cables and they will work normally is that correct? If so please use the link on the left and request an RMA and we will be happy to sent you a new set of cables. Please let me know the case number and I will see it gets done ASAP.
Yeah ugh. I just got a new "Right Speaker" Cable from Canada Computers. Same problem on first use. I am really confused as to what I should do?

EDIT: It turns out to be the AV Cable/ Line In Cable! Aha, turns out it wasn't the power! Anyway is there anything you guys can do about this cable?

Last edited by PocketChange; 04-04-2012 at 09:25 PM.
Reply With Quote


  #4  
Old 04-05-2012, 08:55 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,268
POST ID # = 570953
RAM GUY Reputation: 10
Default

Please fill out an RMA request.
__________________
Support accounts and tickets can be created at https://support.corsair.com.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.