The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-24-2016, 07:34 AM
mouseyflash mouseyflash is offline
Registered User
 
Join Date: Jun 2016
Posts: 1
POST ID # = 859577
mouseyflash Reputation: 10
Default H100i Bit the dust - Extremely loud & High Temps

Hey guys,

So it's been a literal disaster for me over the past 4-5 weeks. First off a power-surge knocked out my PSU the day before a university presentation and Skype job interview, I sprinted out and picked up a HDD enclosure as quick as I could to grab the files off. This put my PC out of commision for 4 weeks until I flew back to the UK (Where I had another PSU).

Basically, I transport my PC (HDD, GPU / Mobo / Ram) and have two cases / two coolers one at my parents house in the UK and one in my rental in AUS (where i'm moving permanently or so I thought until the company went under and i've been forced to come back here for a bit until i can find another job)

Anyway, I landed yesterday and just re-built my PC, cooled by the 2012 Corsair H100i which has been incredibly faithful to me over the past 4 years, the LED's on it have since died. Anyway I went to boot it up, as i do each time I rebuild into BIOS and noticed that the pump was making a horrendous grinding sound and chugging almost, the temps were at 91*C and the RPM of the pump was 340. I've pretty much come to the conclusion already that it's completely broken and I'll have to wait until I'm back in AUS in 1-2 months with my other cooler (and take this PSU with me) but I was wondering if anyone has a miracle fix or any crazy solutions to fix it up?

Thanks all!
Reply With Quote


  #2  
Old 06-25-2016, 07:03 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 859724
Toasted Toasted Reputation: 108
Default

Corsair provides a five year warranty for their Hydro series coolers.

Contact Corsair and see whether you can get the H100i replaced via a RMA.
https://corsair.secure.force.com/
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.