The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 11-06-2015, 07:55 AM
sybilance sybilance is offline
Registered User
 
Join Date: Nov 2015
Posts: 2
POST ID # = 818311
sybilance Reputation: 10
Default Corsair H2100 not turning on

Hey guys, I hope you can help me with this.
I've had these Corsair Headphones for about a week, and have used them on an off for that period, only having to fully charge them when I got them. Today I was gaming for 3 ish hours and the Headphones suddenly turned off. I assumed that this was because they ran out of charge as I could hear the beeping. They have been plugged in, charging for an hour and a half-ish and they are not turning on, with the charging port slowly flashing amber. Even when taking out the charging cord and attempting to turn them on, they will not. I'm not sure if this is software problems, or problems with the actual headset.
IF you need any more info, just ask
Thanks
Syb
Reply With Quote


  #2  
Old 11-06-2015, 07:58 AM
sybilance sybilance is offline
Registered User
 
Join Date: Nov 2015
Posts: 2
POST ID # = 818312
sybilance Reputation: 10
Default

Scratch that, they just started working again. I'll come back to this post if they mess up again :)
Thanks anyway
Syb
Reply With Quote


  #3  
Old 11-13-2015, 08:24 PM
XxCrimsonChaos XxCrimsonChaos is offline
Registered User
 
Join Date: Nov 2015
Posts: 2
POST ID # = 819914
XxCrimsonChaos Reputation: 10
Default

I am having this same problem. Wont turn on, dongle seems to be working, charging port on headset seems to be working (slow flashing orange). Any solutions? Bought 9 months ago. :(
Reply With Quote


  #4  
Old 11-13-2015, 08:48 PM
XxCrimsonChaos XxCrimsonChaos is offline
Registered User
 
Join Date: Nov 2015
Posts: 2
POST ID # = 819918
XxCrimsonChaos Reputation: 10
Default

Welp! I assume it was just really dead? After charging it longer it did turn on and is working!
Reply With Quote


Reply

Tags
h2100, not working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.