The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 12-13-2018, 10:11 AM
Skoosh Skoosh is offline
Registered User
 
Join Date: Dec 2018
Posts: 1
POST ID # = 985162
Skoosh Reputation: 10
Default Some Red LED's Failing

Hey everyone,

So I just gave my K70 keyboard a quick clean (took all the keys off and washed them, dusted the aluminium). Let the keys dry, and put them back on. I have done this process many times over the past 2-3 years.

But when I plugged it back in, I noticed that a bunch of my red LED's aren't working anymore:
  • F4, 4, R, F, C, Home, Page Down, 5 (numpad), Skip media key -- all of these keys are green when they should be red.
  • F3, 3, E, 0, P, ;, End, Play/Pause key, +(numpad), 0(numpad) -- all display as orange when they should be red.
  • F7, 7, U, J, N -- all display as slightly pink but they should be red.

All other colours appear to work fine on theys keys - it's just red that doesn't work.

I've had this keyboard for a few years and it's definitely not eligible for an RMA. Any solutions, or should I look at getting a new one?
Reply With Quote


  #2  
Old 12-13-2018, 02:44 PM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 609
POST ID # = 985219
Apophis3 Reputation: 12
Default

do a hard reset before deciding it's toast.
Reply With Quote


Reply

Tags
failure, k70, led, red, rgb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.