The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-28-2015, 01:43 AM
subxder subxder is offline
Registered User
 
Join Date: Feb 2015
Posts: 2
POST ID # = 763244
subxder Reputation: 10
Default CX600 stops working, power-ups-briefly issue

I have been using my CX600 on my Asus P7P55D-E LX mobo since 2011. Last night my PC just died. It's the usual "power-ups-briefly" issue, like in my case it's shorter - 1 or 2 seconds.

So I did the paper clip test but I didn't remove PSU from the case. I did remove most of the pins though, especially the ones in mobo. Nothing.

The stand-by LED in my mobo still lights up so I'm sure there's still power.

What's weird though is that when I move the 24-pin plug, it powers up a lil longer, 3-4 or even 5 seconds but dies again.

I will call Corsair tom but I will appreciate if anyone could give me some insights on my predicament. Could it be the mobo this time since there's still the "brief power up" moment or is this a classic PSU retirement symptoms?
Reply With Quote


  #2  
Old 02-28-2015, 01:49 PM
jonnyguru jonnyguru is offline
PSU GUY
jonnyguru's PC Specs
 
Join Date: Feb 2003
Posts: 2,882
POST ID # = 763332
jonnyguru jonnyguru Reputation: 179
Send a message via ICQ to jonnyguru Send a message via MSN to jonnyguru Send a message via Yahoo to jonnyguru Send a message via Skype™ to jonnyguru
Default

If you do the paper clip test, you should unplug everything from the PSU except for maybe one fan. Because that the PSU is plugged into could be bad and causing the short circuit protection to latch the PSU off.
Reply With Quote


  #3  
Old 03-01-2015, 12:22 AM
subxder subxder is offline
Registered User
 
Join Date: Feb 2015
Posts: 2
POST ID # = 763465
subxder Reputation: 10
Default

I've extracted it already and tested it with one fan attached. It's the same brief power-on behavior. This could be a mobo then. Thanks for the suggestion.
Reply With Quote


Reply

Tags
asus, cx600, power failure

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.