The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cases

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-25-2019, 12:31 AM
Jakomelo Jakomelo is offline
Registered User
Jakomelo's PC Specs
 
Join Date: Jun 2019
Posts: 2
POST ID # = 1009224
Jakomelo Reputation: 10
Default RGB Fan lights immediately blew out.

Heyo. I upgraded to the gorgeous 570x case a week ago and hooked everything up no problem. When I went to turn it on for the first time, the LEDs in the fans instantly went out and I smelled a bit of smoke.
They still spin but don't light up at all and the controller for them seems to do nothing. Anyone else have this issue or know what went wrong?
Also I put in a support ticket 6 days ago and have yet to receive a response...does it usually take this long?! ID is #2000454205
Reply With Quote


  #2  
Old 06-25-2019, 12:55 AM
Zotty's Avatar
Zotty Zotty is offline
CORSAIR Beta Team
Zotty's PC Specs
 
Join Date: Apr 2017
Location: South Staffordshire, England, UK
Posts: 3,034
POST ID # = 1009227
Zotty Reputation: 52
Default

Hi buddy.... locate the RGB Fan LED Hub and check its cabling? specifically its Sata power Cable...how's it look?

more info below for what devices are and what they do..

http://forum.corsair.com/v3/showthread.php?t=173880
Reply With Quote


  #3  
Old 06-25-2019, 12:55 AM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,506
POST ID # = 1009228
DevBiker Reputation: 88
Default

It's not a common issue. What went wrong? Hard to say. One thing we've seen is that folks don't use the cables that come with their modular PSU - that can tend to mess things up. Outside of that, we've also seen occasional issues with mis-wired cables from the factory (only once or twice) and ... well ... just plain bad luck.
So ... I'd check and make sure that your power cables are correct. Outside of that ... hopefully you'll get a reply from support.
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Reply With Quote


  #4  
Old 06-25-2019, 09:07 AM
Jakomelo Jakomelo is offline
Registered User
Jakomelo's PC Specs
 
Join Date: Jun 2019
Posts: 2
POST ID # = 1009260
Jakomelo Reputation: 10
Default

Thanks you two. I checked the wires for the hub as well as the sata cables (which are connected to the original PSU cables) and found nothing melted or burned.
Everything is where it should be so this has just left me confused and with less money in my wallet...Hopefully I'll be able to get a replacement.
I will check out that thread though Zotty since I have some down time. Thanks!
Reply With Quote


  #5  
Old 06-25-2019, 12:21 PM
Zotty's Avatar
Zotty Zotty is offline
CORSAIR Beta Team
Zotty's PC Specs
 
Join Date: Apr 2017
Location: South Staffordshire, England, UK
Posts: 3,034
POST ID # = 1009285
Zotty Reputation: 52
Default

Quote:
Originally Posted by Jakomelo View Post
Thanks you two. I checked the wires for the hub as well as the sata cables (which are connected to the original PSU cables) and found nothing melted or burned.
Everything is where it should be so this has just left me confused and with less money in my wallet...Hopefully I'll be able to get a replacement.
I will check out that thread though Zotty since I have some down time. Thanks!

OK man.. good luck :).. hope you get sorted
Reply With Quote


Reply

Tags
crystal 570x, fan controller, rgb fans, shortage, ticket

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.