The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 03-29-2018, 01:05 PM
momorious's Avatar
momorious momorious is offline
Registered User
momorious's PC Specs
 
Join Date: Jul 2016
Posts: 263
POST ID # = 947507
momorious Reputation: 12
Default K95 Platinum not working with Windows Insider Version 17133

Hi!
I am a Windows Insider in the fast ring and tried updating from 17128.1 to 17133.1 now 3 times but always the same: This new Windows build broke the Corsair K95 Platinum Keyboard. It is not lighting up at all, it is not detected in iCue and it is shown as a unknown HID in the device Manager in Windows with a yellow warning sign.
Rolling back to 17128.1 Always solved the issue and the K95P is working again.

I dont actually know if its a windows issue or a iCue or a hardware issue but 17133.1 is supposed to be the next Windows version Spring Creators Update (RTM version) so this issue cant be rolled over to the public and needs investigation from Corsair and Microsoft so I post this here.
Reply With Quote
  #2  
Old 03-29-2018, 04:26 PM
Corsair CJ's Avatar
Corsair CJ Corsair CJ is offline
Corsair Employee
Corsair CJ's PC Specs
 
Join Date: Jul 2016
Location: Corsair HQ
Posts: 677
POST ID # = 947544
Corsair CJ Reputation: 42
Default

Have you tried reinstalling iCUE after installing the Windows Insider update? Let me know if that resolves this and I'll ask our team to look into this on our end.
Reply With Quote
  #3  
Old 03-29-2018, 04:35 PM
momorious's Avatar
momorious momorious is offline
Registered User
momorious's PC Specs
 
Join Date: Jul 2016
Posts: 263
POST ID # = 947546
momorious Reputation: 12
Default

Yes, beside installing the Insider version 3 times I also tried reinstalling iCue but the K95 is still dead.
Its even dead when the pc boots so iCue isnt even loaded, just like the USB device is not registered at all by the pc. The lighting of the Keyboard just lights up for 3 seconds directly after I pressed the power button to turn on the pc, then all Corsair stuff goes blank, Windows tries to load all USB devices again and the K95P is dead at that point.
All other usb devices are working fine (including Glaive RGB, MM800C and other USB devices). Its just the K95P which is dead.. I became a Windows Insider just lately with Build 17115 on the 9th March to get a first glimpse whats new in the new Win 10 Update and never got any issues with Corsair gear in all the published builds but 17133 is very likely the RTM build for the Spring Creators Update and I think this issue needs to get resolved before it hits all users in mid April.. :/
Reply With Quote
  #4  
Old 03-29-2018, 05:28 PM
totorman totorman is offline
Registered User
totorman's PC Specs
 
Join Date: Mar 2018
Posts: 24
POST ID # = 947569
totorman Reputation: 10
Default

Might be a driver issue because i'm also in 17133.1 but with a K70 lux rgb and all is working well.
BUT :) i was with CUE when Windows updated itself. I installed iCue after.

I remember i had some same issues using my Steelseries apex m800, at each software update, the lock keys didnt want to light on/off, they were always on. To get it to work well i was forced to uninstall the device in HID Devices (in device manager) and then Windows was reinstalling itself the good driver.
Reply With Quote
  #5  
Old 03-29-2018, 09:56 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,454
POST ID # = 947592
Corsair James Reputation: 75
Default

I need to know the error in Device Manager in the Insider Build. Usually its code 52 in my experience which is a failure of Windows to recognize their own signature in drivers (a common issue with unreleased builds).
__________________

iCUE - A CORSAIR Interface
https://www.corsair.com/us/en/icue
Reply With Quote
  #6  
Old 04-10-2018, 02:48 PM
momorious's Avatar
momorious momorious is offline
Registered User
momorious's PC Specs
 
Join Date: Jul 2016
Posts: 263
POST ID # = 949580
momorious Reputation: 12
Default

Did you reproduced the issue?
I gave the Spring Creators Update Insider Build 17133.73 /which is most likely THE final build) another chance today but still have the issue which makes it completely impossible to actually use Windows 10 1803 Spring Creators Update.
If this gets released to the public I think Corsair has a BIG problem.

Here you can find a video which shows the exact moment where the K95P looses connection during the installation process. It happens at 43% of the install of the 17133 update.


You can see the K95P goes black and does not recover. MM800 and Glaive are still lighting.

And here you can see what happens when my PC boots:


As you can see at first directly after pressing the power-on button the K95P lights up together with the MM800 and Glaive. Then all devices go black. But when the windows logo appears, the USB devices get another boot and only the MM800 and Glaive are lighting up again - the K95P stucks black and is completely dead.

This is what the device manager shows:

https://1drv.ms/u/s!AmpzWY6tGIepgrMwkltOGvo3htSAZw

https://1drv.ms/u/s!AmpzWY6tGIepgrMxKM_OXLFQv-MD5g

The keyboard is listed 3 times as a unknown device and in the properties page there is a error code 28 which is in conflict with the ASMedia USB Host it seems.

Please get in contact with Microsoft before they roll out the SCU in the next days... There is NO problem with the previous Insider Build 17128 so I dont know what they did with 17133 but the K95P is dead.
Reply With Quote
  #7  
Old 04-11-2018, 01:11 AM
momorious's Avatar
momorious momorious is offline
Registered User
momorious's PC Specs
 
Join Date: Jul 2016
Posts: 263
POST ID # = 949640
momorious Reputation: 12
Default

I Google this error code 28 which I get in the device manager and it says that this error code happens when no driver was installed for that device.
So during the installation of 17133 the driver was not installed. Is there a way to install the device driver manually? When I try the automatic search no driver was found.. And iCUE does also not install the driver...
Reply With Quote
  #8  
Old 04-12-2018, 12:19 AM
momorious's Avatar
momorious momorious is offline
Registered User
momorious's PC Specs
 
Join Date: Jul 2016
Posts: 263
POST ID # = 949829
momorious Reputation: 12
Default

Anything from Corsair related to this?
Reply With Quote
  #9  
Old 04-17-2018, 01:26 AM
momorious's Avatar
momorious momorious is offline
Registered User
momorious's PC Specs
 
Join Date: Jul 2016
Posts: 263
POST ID # = 950671
momorious Reputation: 12
Default

K95 Platinum is still not usable with today's latest Insider 17134!!!!!!!
Please Corsair, get in contact with Microsoft ASAP. This needs to get resolved before 1803 will be released as that update would crash thousands of keyboards!!!
Reply With Quote
  #10  
Old 04-17-2018, 06:48 AM
paybax paybax is offline
Registered User
paybax's PC Specs
 
Join Date: Mar 2018
Location: Canada "The Great White North" :)
Posts: 10
POST ID # = 950698
paybax Reputation: 10
Default

Quote:
Originally Posted by momorious View Post
K95 Platinum is still not usable with today's latest Insider 17134!!!!!!!
Please Corsair, get in contact with Microsoft ASAP. This needs to get resolved before 1803 will be released as that update would crash thousands of keyboards!!!
Hi momorious,
If I may get n on this discussion. Where does one go to find this “17134”....and what type of driver is it ? Point me n the direction to go and I’ll check mine.

I had a blank board issue that was resolved, and I may be able to help. I bought my board about a month ago. Had some issues, and now it’s solved. Sounds similar to mine.

I won’t bore you with my problem until. Find out what that 17134 is, and where do I find out mine.
Hope I can help
Reply With Quote
  #11  
Old 04-17-2018, 06:56 AM
momorious's Avatar
momorious momorious is offline
Registered User
momorious's PC Specs
 
Join Date: Jul 2016
Posts: 263
POST ID # = 950699
momorious Reputation: 12
Default

Quote:
Originally Posted by paybax View Post
Hi momorious,
If I may get n on this discussion. Where does one go to find this “17134”....and what type of driver is it ? Point me n the direction to go and I’ll check mine.

I had a blank board issue that was resolved, and I may be able to help. I bought my board about a month ago. Had some issues, and now it’s solved. Sounds similar to mine.

I won’t bore you with my problem until. Find out what that 17134 is, and where do I find out mine.
Hope I can help
17134 is the Windows Insider version in the fast ring, most likely to become RTM build for Windows 10 1804 Spring Creators Update.
Reply With Quote
  #12  
Old 04-17-2018, 02:02 PM
Tairom Tairom is offline
Registered User
Tairom's PC Specs
 
Join Date: Aug 2017
Posts: 28
POST ID # = 950749
Tairom Reputation: 13
Default

I am on 17134 using K95P without issue (now). It is a laugh, but what I found was after the update, somehow the keyboard brightness (little snowflake button) was set to off of the 4 possible positions. I was unplugging and replugging the keyboard, doing hard and soft resets to it, ect. to no avail. I decided to just hit the brightness button for the hell of it and lo-and-behold, there were my lights once again. XD
Reply With Quote
  #13  
Old 04-17-2018, 02:10 PM
momorious's Avatar
momorious momorious is offline
Registered User
momorious's PC Specs
 
Join Date: Jul 2016
Posts: 263
POST ID # = 950752
momorious Reputation: 12
Default

Quote:
Originally Posted by Tairom View Post
I am on 17134 using K95P without issue (now). It is a laugh, but what I found was after the update, somehow the keyboard brightness (little snowflake button) was set to off of the 4 possible positions. I was unplugging and replugging the keyboard, doing hard and soft resets to it, ect. to no avail. I decided to just hit the brightness button for the hell of it and lo-and-behold, there were my lights once again. XD
Unfortunately thats not the issue I have. The keyboard is dead with the latest Insider build. Without the virtual keyboard I wouldnt even be able to login and reset back to the old 17128...
Reply With Quote
  #14  
Old 04-17-2018, 02:19 PM
Tairom Tairom is offline
Registered User
Tairom's PC Specs
 
Join Date: Aug 2017
Posts: 28
POST ID # = 950753
Tairom Reputation: 13
Default

OK, let us see what we can do... Let's start basic.

Have you tested the keyboard in different usb 3.0+ ports?

Have you tested a different device in the port you are plugging the keyboard into to verify that that port is functioning correctly?

If you are using ASUS's ASMedia 3.1 ports, have you checked for an ASMedia driver update?

Tried to uninstall and reinstall the ASMedia drivers?

Have you hard reset the keyboard Plug it into the usb port while holding the [esc] key)?

Have you disconnected all other USB devices and tried ONLY the keyboard, just to see if we are having assignment issues?

Try these minor things and let me know. You and I have very similar base equipment (just a generation off) so maybe we can comparatively troubleshoot the issue.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.