The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-24-2011, 07:21 PM
(FIH) The Don (FIH) The Don is offline
Registered User
(FIH) The Don's PC Specs
 
Join Date: Feb 2011
Posts: 1
POST ID # = 490835
(FIH) The Don Reputation: 10
Default TX850W, or is it TX950W with 850 sticker

hey guys

first post here :)

i bought the TX850W PSU from our local webshop the other day

and today im sitting with it infront of my, building my rig, and i notice something strange

bc on your homepage it says its supposed to have 4x6+2pin pci-e cables.....but this one has 6x6+2pins.

so i took a look at the tx950W specs, and it is supposed to have those 6x6+2pins

so im thinking, was it wrongfully labelled from your side, or did it grow another set of pci-e cables
Reply With Quote


  #2  
Old 02-24-2011, 09:08 PM
Wired's Avatar
Wired Wired is offline
Administrator
Wired's PC Specs
 
Join Date: Aug 2000
Posts: 32,188
POST ID # = 490857
Wired Reputation: 32
Default

Sounds like it just came with extra cables.
__________________
No, I don't work for Corsair
...you need to flow like a river...
Forum Rules
Admin of this forum / webdesignforums.net / Petri's IT Forum / The Corsair Memory Steam Group
Founder/Creator/Admin of ZE SECRET PROJECT (Coming Soon)
Reply With Quote


  #3  
Old 02-25-2011, 09:55 AM
self_slaughter self_slaughter is offline
Registered User
 
Join Date: Feb 2011
Posts: 1
POST ID # = 490909
self_slaughter Reputation: 10
Default

Yeah I just got a new TX850 myself the other day and was surprised to see 6 pci-e cables hanging off it instead of 4....
Kinda annoying really since I bought the 850 instead of the 950 so I'd have less cables to hide lol

Quote from Hardforum
Quote:
Redbeard Official Corsair Rep., 5.3 Years

Status:
Okay, that's not a TX950. I just checked with some guys at work and apparently a few of the newer TX850s rolled off the production line with 6x PCI-E connectors instead of four. A manufacturing flaw that has been addressed already. Unfortunately (or fortunately, depending on how you look at it) a few of those are already in the market.

So it's not a TX950, it's a newer TX850, and it has six connectors by accident.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.