The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-21-2020, 02:49 PM
Fatalboloto Fatalboloto is offline
Registered User
Fatalboloto's PC Specs
 
Join Date: Aug 2020
Posts: 1
POST ID # = 1058379
Fatalboloto Reputation: 10
Default Corsair HS70 Pro Wireless Turn on and off Problems

Hey there! So last week I got a brand new Corsair HS70 Pro Wireless. Worked perfectly till last night.

To turn it on I used to hold the button no more than 2 seconds and now even holding for almost 10 does nothing. Same for shutting it down too. Sometimes it takes AGES to shut it down.

Its that a problem that I can fix doing something on iCUE or do I need to ask for a replacement?

Thanks in advance.
Reply With Quote


  #2  
Old 09-11-2020, 10:35 AM
Corsair Elito Corsair Elito is offline
Corsair Employee
 
Join Date: Sep 2019
Posts: 62
POST ID # = 1060871
Corsair Elito Reputation: 10
Default

Hi

Many similar issues on our HS70 can be solved by doing a Soft-Reset. This will disconnect the battery from the headset, and then reconnect it. All you need to do is:
1.Make sure your HS70 is powered off.
2.Hold the Mute button on the HS70 headset down for about 15-20 seconds
3.After holding the Mute button wait 15 seconds and then hold the Power button until the HS70 turns on.

Then try testing the headset. If it is still having issues, Contact Support @ https://help.corsair.com/hc/en-us

They can help you with this issue.
Reply With Quote


  #3  
Old 09-20-2020, 10:33 AM
zaphodikus zaphodikus is offline
Conrad
zaphodikus's PC Specs
 
Join Date: Aug 2020
Location: UK
Posts: 15
POST ID # = 1062066
zaphodikus Reputation: 10
Default

I am noticing that when turning it on, it takes a long time sometimes, I then end up turning it off, and then on - almost as if the driver is struggling to start/stop or something. Just sometimes. Hope that's what you are seeing if the revert firmware does not resolve it.
Reply With Quote


  #4  
Old 09-21-2020, 01:31 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 1,210
POST ID # = 1062226
Corsair Nick Reputation: 39
Default

Quote:
Originally Posted by zaphodikus View Post
I am noticing that when turning it on, it takes a long time sometimes, I then end up turning it off, and then on - almost as if the driver is struggling to start/stop or something. Just sometimes. Hope that's what you are seeing if the revert firmware does not resolve it.
Where do you have your dongle for the headset plugged in? Try moving it to a closer location that is in line of site with the headset and see if that improves the start up time.
Reply With Quote


  #5  
Old 10-01-2020, 04:43 AM
zaphodikus zaphodikus is offline
Conrad
zaphodikus's PC Specs
 
Join Date: Aug 2020
Location: UK
Posts: 15
POST ID # = 1063559
zaphodikus Reputation: 10
Default

Having this problem myself too now. And the headset is pretty rubbish after working fine for ages - I use the headset on 2 computers.

1. plug in dongle, wait about 5 seconds
2. turn on headset , wait 5 seconds
Now around 1/4 attempts, it will work, but mostly, I have to turn off headset, turn on headset - do this very slowly else it gets twisted

Mostly - unplug dongle , wait, replug dongle, wait, unplug dongle, wait, the replug it. then it will work.

It seeeeeems like this works
1. plug in dongle, turn on headset - ignore the nonworkingness
2. unplug, wait 15 sec, plug in dongle.

Any idea why guys?

Last edited by zaphodikus; 10-01-2020 at 04:46 AM.
Reply With Quote


  #6  
Old 10-02-2020, 09:08 AM
zaphodikus zaphodikus is offline
Conrad
zaphodikus's PC Specs
 
Join Date: Aug 2020
Location: UK
Posts: 15
POST ID # = 1063711
zaphodikus Reputation: 10
Default

I have now turned off the "auto-power off"
I have now turned off voice prompts

I'm not getting any more pointers, and if the above "disable" settings don't work I'll be raising a ticket, It takes almost 5 minutes to get the headset working every morning and again every evening, it's not a good waste of time.

1. plug in and wait for it to not work (headset must be in "up-boop" or connecting mode)
2. unplug dongle, wait at least 1 minute
3. plug dongle. toggle headset off and then on, very slowly wait a decent while between presses.

Not good enough.
Reply With Quote


  #7  
Old 10-24-2020, 04:54 AM
zaphodikus zaphodikus is offline
Conrad
zaphodikus's PC Specs
 
Join Date: Aug 2020
Location: UK
Posts: 15
POST ID # = 1066729
zaphodikus Reputation: 10
Unhappy

Even after doing the "reset", It still does not pair reliably.
I have 2 computers, and 50% of the time when I plug in the dongle, it wont work on either machine. have to often wait about 15 seconds, unplug, wait 15, and then replug the dongle.

I'm quite disappointed and have already had to dissuade people from buying this set, they are nice and comfortable and work really well, when they pair that is.

The annoying thing is when they are in their "fail to pair" state, turning them on I hear a 1/2 second of computer audio after the boop-beep, but they are then "dead" . The fact it works most of the time makes it hard for me to just ask for an RMA, but the stress this product that should work, and is otherwise great, is creating is not worth the pain.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.