The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-23-2019, 11:36 AM
Caldwell Caldwell is offline
Registered User
 
Join Date: Aug 2019
Posts: 4
POST ID # = 1015478
Caldwell Reputation: 10
Default Sidetone not working in new VOID Pro RGB

Well, you can imagine my frustration, new headset, read the hype and took the plunge and bought it. Void Pro RGB 'USB'.

The sound quality is excellent however my Sidetone feature doesn't work (a reason why I chose this product).

Attempted remedies using Win10 Home

1: Reinstalled ICUE (latest version 3.18.77)
2: Updated firmware (FW 0.01)
3: Followed the instructions on the setup to the letter...
4: Tried different USB ports
5: Tested Mic (works)
6: Reinstalled drivers
7: Ensured that Void pro is set to default both Headset and Mic!

The only thing that give sidetone feed back is 'Listen to device' in the Recording tab, but its delayed, has an echo and cannot be volume controlled.

I dont know what else I can do but sent it back and purchase a new headset from a different brand.

HELP!

EDIT: Just testing the headset on a Win 7 system, still no Sidetone. I suspect its broke!

On my current system the Drivers in Device manager display: MS 10.0.18362.1 a Microsoft Signer, same with the Mic. Not Corsair!

Last edited by Caldwell; 08-23-2019 at 01:36 PM.
Reply With Quote


Reply

Tags
void pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.