The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 03-16-2020, 01:36 PM
eplossl eplossl is offline
Registered User
 
Join Date: Mar 2020
Posts: 2
POST ID # = 1038000
eplossl Reputation: 10
Default HS70 headset mic won't unmute

I am having an issue with my HS70 mic not unmuting. If I plug the dongle into my home desktop machine, the mute button works correctly. Everything there seems to work just fine.

However, when I plug the dongle into my work laptop, the headset will work properly until I press the mute button the first time. The first time I press the button, it'll mute the headset. However, if I press the button again, although the iCue software shows that the headset goes from muted to unmuted, but the voice/beep doesn't state that the headset unmuted and Windows cannot hear any audio from the mic.

I have tried unplugging the dongle and replugging it, uninstalling the drivers and the iCue software and reinstalling, and power cycling the headset and the computer. None of that seems to work. I have also verified that the headset is fully charged and the Human Interface Service is running.

The only thing that seems to work is to move the headset dongle to the other computer, make sure the headset connects, then unmute it (so that it says that it has unmuted). I can then move the headset back to the impacted machine and it'll work until I press the mute button again.
Reply With Quote


  #2  
Old 03-19-2020, 07:54 PM
eplossl eplossl is offline
Registered User
 
Join Date: Mar 2020
Posts: 2
POST ID # = 1038303
eplossl Reputation: 10
Default So it's worse now...

So I updated the version of the software on my home computer the other day, while trying to troubleshoot this issue on my work machine. Now my home computer won't unmute the mic when I press the button anymore. This leads me to the suspicion that the problem is in some version of the software on or around 3.25.60.

I'm including the system info and logs export available via the application.
Attached Files
File Type: zip Home headset.zip (56.5 KB, 16 views)
Reply With Quote


  #3  
Old 03-21-2020, 03:14 PM
YaboiPhteven YaboiPhteven is offline
Registered User
 
Join Date: Mar 2020
Posts: 1
POST ID # = 1038432
YaboiPhteven Reputation: 10
Default Same problem

I am having the same problem, it just started yesterday. If I unplug the dongle from my laptop it makes the mute/unmute beep sounds when I press the button, but if my dongle is inserted it auto-mutes the mic and I cannot unmute it. According to the iCUE app, it is being muted and unmuted when I press the button, but it does not make the beep sound and doesn't actually transmit sound when I talk (using discord). Pls help.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.