The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 05-31-2019, 08:29 AM
LetoSB LetoSB is offline
Registered User
LetoSB's PC Specs
 
Join Date: May 2019
Posts: 1
POST ID # = 1006386
LetoSB Reputation: 10
Exclamation H100i rgb platinum pump noise

My pump is making a loud noise for the past 4 days, it’s a very loud humming noise and when I start a game it makes a rattling noise. To be clear when I got it first it used to make absolutely no noise. Fans and pump are running on quiet via icue

rattling noise https://streamable.com/mhbq5

humming noise https://streamable.com/eeudw
Reply With Quote


  #2  
Old 05-31-2019, 12:56 PM
CoMa CoMa is offline
Registered User
 
Join Date: Apr 2009
Posts: 10
POST ID # = 1006410
CoMa Reputation: 10
Default

Mine too, quiet mode it's not so quiet... i opened a ticket too
Reply With Quote


  #3  
Old 07-15-2019, 02:56 PM
Sylvaz Sylvaz is offline
Registered User
 
Join Date: Jul 2019
Posts: 3
POST ID # = 1011368
Sylvaz Reputation: 10
Default

I have the same problem so its normal or not ? But only in the quite mode ... in balance it has a little noise and extreme mode it totally gone

Last edited by Sylvaz; 07-15-2019 at 03:10 PM.
Reply With Quote


  #4  
Old 07-15-2019, 10:22 PM
DevBiker's Avatar
DevBiker DevBiker is offline
iCue βeta Team Green
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,256
POST ID # = 1011433
DevBiker Reputation: 88
Default

This isn't uncommon with the Platinum coolers. I would suggest that you leave it in Balanced or Extreme. Quiet not only isn't quiet, it also negatively impacts your temperatures. The difference between Balanced and Extreme on temps in negligible.
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Reply With Quote


  #5  
Old 07-16-2019, 04:37 AM
Sylvaz Sylvaz is offline
Registered User
 
Join Date: Jul 2019
Posts: 3
POST ID # = 1011453
Sylvaz Reputation: 10
Default

So it isn't normal then ?
Reply With Quote


  #6  
Old 07-16-2019, 08:16 AM
DevBiker's Avatar
DevBiker DevBiker is offline
iCue βeta Team Green
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,256
POST ID # = 1011477
DevBiker Reputation: 88
Default

Quote:
Originally Posted by Sylvaz View Post
So it isn't normal then ?
It's not uncommon ... which means that it's pretty usual.
Seriously - set it to Balanced. You don't lose anything (doesn't impact lifetime), it's quieter AND you won't take a few degrees hit on the cooling.
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Reply With Quote


  #7  
Old 07-16-2019, 09:45 AM
Sylvaz Sylvaz is offline
Registered User
 
Join Date: Jul 2019
Posts: 3
POST ID # = 1011482
Sylvaz Reputation: 10
Default

Oh ok then thanks you for the information
Reply With Quote


  #8  
Old 07-27-2019, 10:57 AM
Speedi's Avatar
Speedi Speedi is offline
Registered User
Speedi's PC Specs
 
Join Date: Dec 2004
Location: Atlanta, GA
Posts: 80
POST ID # = 1012741
Speedi Reputation: 10
Default

Hmm.. I am also experiencing some noise issues with my H100i RGB Platinum cooler. Started about a few months ago, but frankly I didn't want to deal with it so i just let it ride. I have had it for about 8 months in this new build and over the past few weeks it seems to have progressively worsened. I just gave the "Balanced" setting a try, also shut the system down and then turned it back on. Given I just changed a few things, I'll let it play out for a a day or so before taking another look at possibly sending it back if the noise gets worse.

I remember having a similar issue with my H80 back in the day and it was a faulty pump. However, based on some discussions I saw here on the forum, I'll let it play out for a few days.
Reply With Quote


  #9  
Old 08-12-2019, 07:01 AM
Speedi's Avatar
Speedi Speedi is offline
Registered User
Speedi's PC Specs
 
Join Date: Dec 2004
Location: Atlanta, GA
Posts: 80
POST ID # = 1014442
Speedi Reputation: 10
Thumbs up

Quote:
Originally Posted by DevBiker View Post
This isn't uncommon with the Platinum coolers. I would suggest that you leave it in Balanced or Extreme. Quiet not only isn't quiet, it also negatively impacts your temperatures. The difference between Balanced and Extreme on temps in negligible.
OK. I gave it a go to set to BALANCED. It did get significantly quieter.. and now it has dropped my cooling by over 1.5 degrees C. Interesting.
Reply With Quote


Reply

Tags
h100i broken pump, h100i rgb platinum, humming noise, pump noise h100i, rattling noise

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.