The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 05-12-2019, 07:11 AM
pegnose pegnose is offline
Registered User
 
Join Date: Aug 2018
Posts: 24
POST ID # = 1004317
pegnose Reputation: 10
Default iCUE shuts down wireless keyboard connection...

when it is only supposed to switch off the keyboard LEDs. I switched from CUE to iCUE, because I bought a new corsair mouse which apparently was not supported by CUE.

I re-configured everything for my K63 wireless, including the LED Off timer. Now when the LEDs are supposed to go off, the whole wireless connection is shut down. On pressing a key, nothing happens at first and then the yellow pairing LED blinks. After 10 seconds I can use my keyboard again.

WTFRICK.
Reply With Quote
  #2  
Old 05-13-2019, 05:49 PM
Corsair Calico Jack's Avatar
Corsair Calico Jack Corsair Calico Jack is offline
Corsair Employee
 
Join Date: Oct 2016
Posts: 578
POST ID # = 1004488
Corsair Calico Jack Reputation: 10
Default

Maybe the time for the LED's to turn off is the same for the USB to idle?

Please go to CONTROL PANEL / HARDWARE AND SOUND / POWER OPTIONS and then click on CHANGE PLAN SETTINGS (for your current default power plan). After that click on CHANGE ADVANCED POWER SETTINGS.

When new window opens, scroll down the list a bit until you hit USB SETTINGS. Click little square with plus in it, and then click another little square with plus next to USB SELECTIVE SUSPEND SETTING. Check the state of it, and make sure it's set to DISABLED. Then restart the PC.
Reply With Quote
  #3  
Old 05-14-2019, 02:22 AM
pegnose pegnose is offline
Registered User
 
Join Date: Aug 2018
Posts: 24
POST ID # = 1004521
pegnose Reputation: 10
Default

Thank you for the advice, Jack!

My USB selective suspend is OFF. Also the behavior is the same whether I set the LED timeout to 1 or 15 min.

I think it was the firmware update that brought this ****. The keyboard just turns off. I want my old firmware back.
Reply With Quote
  #4  
Old 05-14-2019, 04:06 PM
Corsair Calico Jack's Avatar
Corsair Calico Jack Corsair Calico Jack is offline
Corsair Employee
 
Join Date: Oct 2016
Posts: 578
POST ID # = 1004582
Corsair Calico Jack Reputation: 10
Default

If you create a ticket with us, we can give you the prior firmware. If it does correct it, try updating to the newest firmware again and report back. Would be good to know.
Reply With Quote
  #5  
Old 05-15-2019, 02:33 AM
pegnose pegnose is offline
Registered User
 
Join Date: Aug 2018
Posts: 24
POST ID # = 1004625
pegnose Reputation: 10
Default

I will do that, thank you for the offer.

I can imagine that some people would like what I currently got: they always want their LEDs on but would appreciate their keyboard going full power save when they leave their desk.

I on the other hand would like to stick with the original functionality. Imagine you are watching a twitch stream and chat on occasion. You don't want to wait a couple of seconds every time you'd like to post something in chat. But you also don't want the keyboard to be fully lit all the time, as it drains battery.

I think here applies what applies everywhere else: if you come up with an interesting new functionality, give users the choice, or even let them configure both timeouts (and let them set "0" for disabling the timeout). At least have your UI stating the correct functionality, as "Enable LED auto shut-off" is clearly not correct anymore.

UPDATE: Ticket created.

Last edited by pegnose; 05-15-2019 at 02:51 AM.
Reply With Quote
  #6  
Old 06-21-2019, 01:23 PM
pegnose pegnose is offline
Registered User
 
Join Date: Aug 2018
Posts: 24
POST ID # = 1008809
pegnose Reputation: 10
Default

Shortly after creating my ticket the issue was solved by another official firmware update: all LEDs went off (incl. Power and Wifi), but the wireless connection remained intact.

Today I updated iCUE and found my suggestion implemented: a separate "Sleep mode" timer, which - once enabled - defaults to 60 min. And you can enable and disable both timers via a check box. Perfect choice, and I am glad that Corsair listened! Really happy to have made a good experience for once with a bigger company.

Thank you!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.