The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-12-2016, 08:31 AM
MRetroGamer MRetroGamer is offline
Registered User
 
Join Date: Dec 2015
Posts: 11
POST ID # = 830598
MRetroGamer Reputation: 10
Default Problem with Corsair Gaming H2100 Light

Hello, I just received my Corsair Gaming H2100 headsets and I wanted to try them, but I found a problem. I followed the instructions, I charged it untill the light was green (though I didn't see any ambar light, only red and green lights), I changed it to be my default device and everything went as expected, but the blue light in the headset doesn't work correctly. It only turns on when I keep holding the button, but as soon as I stop holding, it might do a short intermitent lighting before turning off. That's kinda annoying because I can only see when th headset is on by looking at the pen-drive. Do you know how to fix it? I would also appreciate if you know how to fix the ambar light aswell.


Thanks.
Reply With Quote


  #2  
Old 01-13-2016, 05:38 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,338
POST ID # = 830760
Toasted Toasted Reputation: 124
Default

Could possibly be a DOA headset. Have you tried turning the headset on with the charging cable plugged in?

if it doesn't turn on, contact your retailer and see if they can replace the headset for you or request an RMA to replace the headset via Corsair.
https://corsair.secure.force.com/
Reply With Quote


  #3  
Old 01-13-2016, 12:06 PM
MRetroGamer MRetroGamer is offline
Registered User
 
Join Date: Dec 2015
Posts: 11
POST ID # = 830823
MRetroGamer Reputation: 10
Default

Sorry, but I don't know what a DOA headset is xd I haven't tried to turn it on while charging yet, but I've noticed that when I turn the headset on, it does an intermitent light every 5 seconds, so I gues that's how it has to be hahaha I thought it had to be on all the time (when on of course) but I think I can deal with that as long as I can see the light to ensure that it's on.
Reply With Quote


  #4  
Old 01-13-2016, 03:07 PM
MRetroGamer MRetroGamer is offline
Registered User
 
Join Date: Dec 2015
Posts: 11
POST ID # = 830848
MRetroGamer Reputation: 10
Default

But actually, I think I got a problem with this headsets, because I use a TP-Link device so I can connect to Internet, and I've noticed that when I turn on my headset (almost everytime) I loose my conection and it doesn't find my WI-FI but it does find the WI-FI's that are around. Do you know what could it be? By the way, I tried turning on my headset while charging them and still the same, I guess that's how it has to work.
Reply With Quote


  #5  
Old 01-15-2016, 05:53 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,338
POST ID # = 831104
Toasted Toasted Reputation: 124
Default

Could be something related to the TP-LINK dongle? As it is also a wireless device.

Have you tried the headset with the TP-LINK device disconnected? Does the headset work fine?
Reply With Quote


Reply

Tags
h2100, headset, light, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.