The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-15-2014, 06:06 PM
Visible Visible is offline
Registered User
 
Join Date: Jan 2014
Posts: 10
POST ID # = 692816
Visible Reputation: 10
Default Vengeance 1500v2 Horrible Mic quality + Driver issues

Hello, so after receiving the headphones today, I instantly ran into multiple problems of which I weren't quite happy and didn't expect to have from 100 euro headset. So, to start off the mic has horrid Hissing and whine sound while its being used, or it has good quality with minor background white sound, how, now the issue is the drivers, the 1.1 Drivers offer good configuration choices + Working 5.1 and 7.1 surround, while anything above version 2 offer the option to nullify the hissing whine sound, but makes the mic sound extremely bad and the surround wouldn't work @ all.

Now I wanted to revert back to version 1.1 drivers, but as it occurred, once i uninstall v2+ drivers, the 1.1 didn't work, as it would not detect the headphones and each time i would try to open the corsair sound config panel it would ask me to plug in the headphones and not detect them, before than tough, windows would automatically install the default audio drivers and it would work, while in the installation the driver would re-install and fail to install with 1.1 drivers, but it would work if I installed v2+... Generally after 1st day experiences im quite disappointed.

At this point im running BETA Version 2.0.19 drivers, the sound is really good on headphones, but the surround isnt working + the mic sounds like it's been flushed in toilet. Im thinking of returning the headphones :/

Update: I managed to downgrade back to 1.1 Drivers and they sound wayyyy better than 2.0.16/19, the only issue with them is the whine sound, somehow I feel that the 16/19 drivers arent based on 1.1 version and are just a brand new thing that is being made almost from 0.

Update2: So Far ive noticed that its the Razer Surround that enables crisp and perfect 7.1 surround quality! Perfect Deep bass and highly clear trebles, this might be an accident but try this out, use 1.1 drivers and setup razer surround drivers over that, theoretically they should of conflicted but instead, its an amazing sound!

Also to note this fixes 7.1 reverse problems and BF4/3/MW3 runs for me epicly good, and it's like ive gotten 6th sense in game... No more sound crashes after tabbing, and amazingly no hissing/white noise!? WHich kind of surprised me, anyhow just wanted to share this with you guys!
Anyhow, its a decent fix for some time until they release a decent driver, honestly Razer Surround works really good in synergy with 1.1 Sound Control panel and its equalizer!

After prolonged testing - The cracking sound is gone, the mic works perfectly, although there is a small white noise in background and the whining sound is gone, and the sound coming from speakers is 7.1 and its also crystal clear.

Last edited by Visible; 01-16-2014 at 01:44 AM.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.