The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-12-2019, 11:43 AM
Froggy Froggy is offline
Registered User
Froggy's PC Specs
 
Join Date: Oct 2014
Posts: 70
POST ID # = 1017947
Froggy Reputation: 10
Default Razer mouse not recognized anymore

Hi there,
So yesterday I installed Icue for my K95 RGB and now the port that had my Razer trinity plugged in doesn't recognized it anymore...
Yes the port still have juice. I can plug my keyboard in and it works, the mouse itself works in every other ports. I'm posting here because this is the only thing that I have installed since the port decided to not recognized my mouse anymore.

Someone had a similar experience? or knows what to do?
I went in device manager, uninstalled, checked for update on the razer side of things. I've also uninstalled Icue, checked the BIOS and still nothing everything but my mouse work on that port
Reply With Quote
  #2  
Old 09-12-2019, 01:07 PM
robert3892 robert3892 is offline
CORSAIR Beta Team
robert3892's PC Specs
 
Join Date: Jan 2009
Location: Europe
Posts: 497
POST ID # = 1017958
robert3892 Reputation: 49
Default

First try a simple and complete uninstall and reinstall of iCUE. See if that fixes it. If not is the port you're referring to the USB port on the back of the K95? Or on the motherboard?

Please post your complete system specs
Reply With Quote
  #3  
Old 09-12-2019, 01:14 PM
robert3892 robert3892 is offline
CORSAIR Beta Team
robert3892's PC Specs
 
Join Date: Jan 2009
Location: Europe
Posts: 497
POST ID # = 1017959
robert3892 Reputation: 49
Default

On which ports is the mouse recognized and on which port is it not working?
Reply With Quote
  #4  
Old 09-13-2019, 01:19 AM
Froggy Froggy is offline
Registered User
Froggy's PC Specs
 
Join Date: Oct 2014
Posts: 70
POST ID # = 1018030
Froggy Reputation: 10
Default

Quote:
Originally Posted by robert3892 View Post
First try a simple and complete uninstall and reinstall of iCUE. See if that fixes it. If not is the port you're referring to the USB port on the back of the K95? Or on the motherboard?

Please post your complete system specs
I haven’t had the chance to re-instal iCUE yet
The port I’m talking about is on my motherboard (keybot USB port)

Specs:
Windows 8.1
CPU: intel 4790K
Motherboard: Asus Maximus VII Formula
GPU: EVGA GeForce 1060 GTX 6gb
PSU: Corsair RM 850
Memory: Corsair Vengeance 16gb

Last edited by Froggy; 09-13-2019 at 01:43 AM.
Reply With Quote
  #5  
Old 09-13-2019, 01:39 AM
Froggy Froggy is offline
Registered User
Froggy's PC Specs
 
Join Date: Oct 2014
Posts: 70
POST ID # = 1018033
Froggy Reputation: 10
Default

Quote:
Originally Posted by robert3892 View Post
On which ports is the mouse recognized and on which port is it not working?
The only port that doesn’t recognize my mouse is the one that the Razer was plugged in initially (keybot USB port) I’ve tried every other ports on the motherboard and they all detect it.
Turns out that the port that’s malfunctioning only has juice (if I plug the K95 RGB it will light up but no keys are printing on screen, Nothing gets detected in device manager. I’ve tried usb sticks, externals and nothing)
Reply With Quote
  #6  
Old 09-13-2019, 03:31 AM
Zotty's Avatar
Zotty Zotty is offline
CORSAIR Beta Team
Zotty's PC Specs
 
Join Date: Apr 2017
Location: South Staffordshire, England, UK
Posts: 3,044
POST ID # = 1018037
Zotty Reputation: 52
Default

unfortunately time and age of the motherboard is against you. (i also run a 4790k machine).. most likely its bad timing and the port was due to die due to old ago buddy :(.. neither of my 'gaming' usb ports work any more on my Z97 board., Finding a new Z97 board can prove to be expensive also
Reply With Quote
  #7  
Old 09-13-2019, 09:45 AM
Froggy Froggy is offline
Registered User
Froggy's PC Specs
 
Join Date: Oct 2014
Posts: 70
POST ID # = 1018057
Froggy Reputation: 10
Default

It’s pointing that way unfortunately �� bummer
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.