The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-10-2012, 06:18 AM
l3el3op l3el3op is offline
Registered User
 
Join Date: Jan 2012
Posts: 1
POST ID # = 553503
l3el3op Reputation: 10
Default RMA taking longer that expected.

I submitted an RMA request (Case #2486284) to Corsair (Netherlands) for my pair of HS1-USB headset on the 20/12/11 and promptly sent it out to them. They received it on the 2/1/12 and have yet to send me out a replacement. The last email I received from them claimed that once the defective item was received they would aim to send a replacement within 3-5 working days. It has been 8 days so far and it has not been dispatched yet. I appreciate the request was during the holiday period, but I would of liked some feedback (I did send an email to Corsair when 5 days had passed and have yet to receive a reply). I might sound a tad impatient. I just want my headset back.

EDIT: It came today. My case details were not updated thats all. Thanks!

Last edited by l3el3op; 01-10-2012 at 11:41 AM.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.