The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 12-11-2019, 04:10 PM
IJuanTM IJuanTM is offline
Registered User
IJuanTM's PC Specs
 
Join Date: Dec 2019
Posts: 1
POST ID # = 1027131
IJuanTM Reputation: 10
Unhappy Led dying only after 4 months

Hi there,

I've been using the K70 v2 with Red switches for the past 4 months and am absolutely loving the keyboard. The problem tho started last week.

I was just busy with some school work when I noticed my shift key led was way dimmer that others. I tried looking on help forums and on corsairs site for help and the only things I found were, "reset your pc, it should be fixed" and "reinstall the ICue software". Both of these things I did but they didn't fix the problem.

So thats why I came here, hopefully someone can help me.

- Thanks, IJuanTM
Reply With Quote


  #2  
Old 12-12-2019, 03:19 AM
Cruxiaer Cruxiaer is offline
Registered User
Cruxiaer's PC Specs
 
Join Date: Nov 2014
Posts: 36
POST ID # = 1027200
Cruxiaer Reputation: 10
Default

Quote:
Originally Posted by IJuanTM View Post
Hi there,

I've been using the K70 v2 with Red switches for the past 4 months and am absolutely loving the keyboard. The problem tho started last week.

I was just busy with some school work when I noticed my shift key led was way dimmer that others. I tried looking on help forums and on corsairs site for help and the only things I found were, "reset your pc, it should be fixed" and "reinstall the ICue software". Both of these things I did but they didn't fix the problem.

So thats why I came here, hopefully someone can help me.

- Thanks, IJuanTM
Try changing your shift led to solid red, green and blue, so you can figure out if one of the colour died or the whole thing is actually dying. Also have you tried it on another PC or another USB port? Fastest way to find out if its a software fault or hardware fault. If the issue persist across other devices then it is most likely hardware fault, I suggest you RMA it.

Last edited by Cruxiaer; 12-12-2019 at 03:23 AM.
Reply With Quote


  #3  
Old 12-12-2019, 06:02 AM
Zotty's Avatar
Zotty Zotty is offline
CORSAIR Beta Team
Zotty's PC Specs
 
Join Date: Apr 2017
Location: South Staffordshire, England, UK
Posts: 3,355
POST ID # = 1027210
Zotty Reputation: 52
Default

some times its dust/fluff/crumbs sitting over one of the led colors....

try giving it a blast of air

Reply With Quote


Reply

Tags
k70, led brightness, led issue

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.