The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Utility Engine (CUE) 1.x and 2.x

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-13-2018, 07:50 PM
VRocker VRocker is offline
Registered User
VRocker's PC Specs
 
Join Date: Nov 2008
Posts: 13
POST ID # = 944726
VRocker Reputation: 10
Default Please fix the USB drivers

I'm a big user of the Corsair hardware which tie into CUE but lately i'm considering killing the RGB stuff in favour of system stability. I currently have the K70 RGB, M65, MM800 and the Void Pro.

The problem is the crappy USB drivers keep causing system instability. Blue screens, USB disconnections and the occasional 'mouse slowdown' which usually leads to a blue screen or weirdness on the system.
This used to happen on my old system but recently replaced the entire thing (motherboard, cpu, ram, etc) and done a fresh OS installation. Since the same things are happening on the new system i decided to look into it some more.
After analysing several minidumps taken when the system blue screens (most BSODs are Page fault in non paged area) i noticed, after digging REALLY deep, that they all linked back to the CorsairVBusDriver.

So this led me to running Driver Verifier (Built into Windows). Running this against the Corsair drivers with the standard options (Pool tracking, security checks etc) results in a big fat fail. This suggests that there's something not quite right in these drivers and leads me to wonder if Corsair have tried verifying their own drivers...?

I've seen quite a few reports of people claiming system instability until CUE (and the drivers) were removed from the system.

To me it looks like there's a bit of memory corruption in them somewhere which, after some time, causes system issues. Memory corruption in a driver can cause the weirdest of problems and make it look like issues with RAM or even graphics problems.

Could the guys at Corsair PLEASE look at the drivers being shipped with CUE? At the very least could you run it through driver verifier (verifier.exe) and found out why its failing and fix it?
Reply With Quote


 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.