The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-24-2020, 11:12 AM
Troopermaniac Troopermaniac is offline
Registered User
 
Join Date: Aug 2016
Posts: 10
POST ID # = 1035899
Troopermaniac Reputation: 10
Default Why do LL120 fans die so frequently?

This is the 4th time I had to order a LL120 fan and im seriously starting to get ticked off. My LL140's and rgb stips are going strong but this is the 4th fan I have ran into that has mysteriously started doing this.

Ive already tried replacing my lighting node pro. IDK what to do anymore.


Reply With Quote


  #2  
Old 02-24-2020, 12:34 PM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 8,434
POST ID # = 1035907
DevBiker Reputation: 94
Default

Have you tried to RMA rather than reorder?
Not sure why you are seeing so many failures.
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Helpful Links and FAQs:
AIO FAQ | RGB FAQ |
HydroX FAQ | RGB Cables |
iCUE Tips & Tricks

Reply With Quote


  #3  
Old 02-25-2020, 02:43 AM
MrMattyV MrMattyV is offline
Registered User
MrMattyV's PC Specs
 
Join Date: Feb 2020
Posts: 1
POST ID # = 1035975
MrMattyV Reputation: 10
Default

I had this same issue happen with a few of my fans flickering. I had the Lighting Node Pro replaced as well as the RGB hub. The issue just popped up again for me. I noticed that one of the LEDs was flickering more than the others. Went in and checked 1 fan at a time for flickering. Then broke it down to individual LEDs. With that single LED not selected, none of the fans flicker anymore.

I attached a picture of the single lighting channel and the single LED unselected.
Attached Images
File Type: png fans.PNG (177.1 KB, 18 views)
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.