The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-23-2020, 06:17 PM
Talinthis Talinthis is offline
Registered User
 
Join Date: Apr 2017
Posts: 9
POST ID # = 1035837
Talinthis Reputation: 10
Default Alt switch rapidly being pressed without input, how to disable key?

So lately my alt key has been going haywire, looks like i need to rip apart the board and resolder a new switch onto it or something. as of right now i have the CUE program redirecting alt key to scroll lock so my keyboard is actually useable. if you press the metal chassis of the keyboard right below the G6 key the left alt key triggers itself on and off, almost like how a short works

Is there an easy way to turn off the left alt key so i dont have to worry about tons of things happening that i do not want happening? probably some sort of 3rd party program since it doesnt seem possible on CUE from what i have seen. The keyboard was not even useable before i changed the function of the alt key... there are a lot of shortcut commands tied to it.
Reply With Quote


  #2  
Old 02-23-2020, 06:40 PM
c-attack c-attack is online now
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 10,600
POST ID # = 1035844
c-attack c-attack Reputation: 107
Default

iCUE -> Keyboard -> Actions

Change Macro to "disable" in the left part of the drop down menu. Select the ALT key in the picture above to apply it.


Not sure why your keyboard is doing this, but you want to try the soft restart method detailed below and then contact Corsair Tech Support if that does not resolve it.

https://help.corsair.com/hc/en-us/ar...-your-keyboard
Reply With Quote


  #3  
Old 02-23-2020, 07:05 PM
Talinthis Talinthis is offline
Registered User
 
Join Date: Apr 2017
Posts: 9
POST ID # = 1035847
Talinthis Reputation: 10
Default

Quote:
Originally Posted by c-attack View Post
iCUE -> Keyboard -> Actions

Change Macro to "disable" in the left part of the drop down menu. Select the ALT key in the picture above to apply it.


Not sure why your keyboard is doing this, but you want to try the soft restart method detailed below and then contact Corsair Tech Support if that does not resolve it.

https://help.corsair.com/hc/en-us/ar...-your-keyboard
thanks, tried that but didnt work. pretty sure the switch is malfunctioning mechanically since if you even breathe on it you can see it trigger (literally breathe on it, i have it set to change colors whenever a key is pressed) thankfully it is disabled now so i am happy.

i first bought a k95 cherry red that came out of the box and loved it but it came with a D switch that did not work, and my replacement ended up as a speed switch since they did not make the one i wanted anymore. have always hated this thing ever since. Definitely never ended up with what i wanted or what i even purchased. anyway, thanks again.
Reply With Quote


  #4  
Old 02-23-2020, 08:57 PM
c-attack c-attack is online now
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 10,600
POST ID # = 1035862
c-attack c-attack Reputation: 107
Default

Ugh... well I would still contact Corsair Tech Support so they can give you the firmware file and do the hard reset. Obviously if it is a mechanical issue, I am not sure what can be done. If still inside the warranty period, you could RMA - again through the Ticket Support System.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.