The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-04-2018, 02:02 PM
Greatorex Greatorex is offline
Registered User
 
Join Date: Sep 2018
Posts: 2
POST ID # = 971462
Greatorex Reputation: 10
Default Noob PSU Question

Hello all, my Corsair TX650W PSU unfortunately passed away on Friday evening after over 8 years powering my PC.

I replaced it myself with a Corsair VS650 yesterday and PC all working again fine.

My machines BIOS keeps opening though now on start up - is this normal? And do I need to do something to fix it?

Thank you in advance!
Reply With Quote


  #2  
Old 09-06-2018, 04:10 AM
Greatorex Greatorex is offline
Registered User
 
Join Date: Sep 2018
Posts: 2
POST ID # = 971688
Greatorex Reputation: 10
Default

Nobody knows??? :(
Reply With Quote


  #3  
Old 09-06-2018, 08:23 AM
deltaminds deltaminds is offline
Registered User
deltaminds's PC Specs
 
Join Date: May 2018
Posts: 21
POST ID # = 971705
deltaminds Reputation: 10
Default

I never got a VS version, I really don't like it.
Reply With Quote


  #4  
Old 09-22-2018, 08:39 AM
jason1984 jason1984 is offline
Blogger
jason1984's PC Specs
 
Join Date: Sep 2018
Location: USA
Posts: 3
POST ID # = 973723
jason1984 Reputation: 10
Default

What do you mean by BIOS keeps opening on boot up?? Is your system going to BIOS automatically and then you have to exit the BIOS?
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.