The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cases

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-10-2020, 10:51 PM
ander12391 ander12391 is offline
Registered User
 
Join Date: Dec 2015
Posts: 6
POST ID # = 1030897
ander12391 Reputation: 10
Default 680X QC Issues

Has anyone noticed any quality control issues with the 680X Case? No joke I have bought this case 4 times since October. And I have yet to get one with out some defect or damage.

First 680X... IO shield wouldn’t line up properly so half of my USB ports were obstructed
Second 680X... Had a dent on the side panel and was dented behind the plastic front plastic fascia. And there was NO damage to the box that indicated shipping damage
Third 680X... Once again IO shield wasn’t lining up. However it wasn’t as bad as the first time. Only two USB ports were obstructed
Fourth 680X... Side panel bent and will not close... I bent it back in place however it looks like the paint is scratched on the back side where someone forced the side panel to fit in place.

This is kinda ridiculous. I really want this case and maybe I’m being overly peculiar about the condition in which it arrives. But I’ve bought this case 4 times and never have I received a unit that isn’t defective or damaged. I have also tried differed retailers thinking maybe they were the problem. I already have a ticket open with Customer Service. But I really think there’s some QC issues with this line of cases. Maybe I’m too picky but this case is retailing for 260 and with tax and shipping it’s pushing 300 USD. This whole experience is starting to remind me why I i stoped using Corsair for cases. Last one I had was the Air 540 and the 680X and Corsair as a company has been a huge disappointment.

Last edited by ander12391; 01-10-2020 at 10:54 PM.
Reply With Quote


  #2  
Old 01-11-2020, 01:39 AM
KILLER_K KILLER_K is offline
Registered User
KILLER_K's PC Specs
 
Join Date: Jul 2008
Posts: 110
POST ID # = 1030907
KILLER_K Reputation: 10
Default

The only issues that I had with mine was. 1 of the silver feet had a big scratch on it. And my glass door makes an annoying squeak every time it is opened. That was about it for me. Nothing to really bother me but it was a little annoying.

Me being subjective:

I really wished that they would have given me a 5 1/2 mount on the other side vertical for all the empty rooms though. Miss my encoding for PLEX. And some fans for the other side of the drive bay section. It gets a little toasty in there. A couple of 120 on that front side would have been great. Or someplace to mount some fans to get some air moving on that side in general.

One more LL120 RGB for the back would have made it so much better. No one on earth thinks a cheap none RGB fans go well with 3 RGB fans Corsair? Maybe a larger black bar around the side window. To cover the bottom and top rads, etc would have been nice for me. And lastly, the front glass panel removal is just sad. Just add 4 or 6 standoff screws as the top had for easy removal. Not a lot of air actually comes through there and with the glass gone it is a lot better airflow. As you would have more options to choose from.

But that is just me being subjective though. Probably if I had to do it over again. I would go a different route though.


Side Note:

Perhaps try another store or open it before you leave the store to check it. But that is pretty bad on such an expensive case.

Last edited by KILLER_K; 01-11-2020 at 01:46 AM.
Reply With Quote


  #3  
Old 01-11-2020, 02:24 PM
KILLER_K KILLER_K is offline
Registered User
KILLER_K's PC Specs
 
Join Date: Jul 2008
Posts: 110
POST ID # = 1030974
KILLER_K Reputation: 10
Default

I hope it all works out for you. Maybe contact Corsair and tell them your issues. Give them the numbers off it so they can have a look to see what is going on. It could have been an early Monday or late Friday build batch.

Last edited by Wired; 01-11-2020 at 09:25 PM. Reason: CC of rule violation
Reply With Quote


  #4  
Old 01-11-2020, 04:34 PM
ander12391 ander12391 is offline
Registered User
 
Join Date: Dec 2015
Posts: 6
POST ID # = 1030987
ander12391 Reputation: 10
Default

Yeah in my most recent ticket with Corsair I submitted all of the invoices from every time I’ve boughten the case.
Reply With Quote


  #5  
Old 01-11-2020, 08:27 PM
KILLER_K KILLER_K is offline
Registered User
KILLER_K's PC Specs
 
Join Date: Jul 2008
Posts: 110
POST ID # = 1031011
KILLER_K Reputation: 10
Default

I just checked my case and it doesn't sit flat on the desk. One of the corners is off a bit. It could be a foot or anything. But it doesn't sit flat as it should.

Last edited by Wired; 01-11-2020 at 09:25 PM. Reason: Rule violation - #8
Reply With Quote


  #6  
Old 01-14-2020, 01:26 PM
Duncan_Lance's Avatar
Duncan_Lance Duncan_Lance is offline
Registered User
Duncan_Lance's PC Specs
 
Join Date: Jan 2020
Location: Luxembourg
Posts: 14
POST ID # = 1031344
Duncan_Lance Reputation: 10
Default

Ordered mine 2 weeks ago and it arrived yesterday. Although there are no visible issues on or in the case itself I really don't get the strategy behind it. I mean, I ordered a white model for a white build and it kinda sucked that I had to buy additional 4 white LL120er fans to replace the stock ones. Why not simply adding white fans from factory for a reasonable extra charge? Moreover I never saw someone keeping the non-RGB fan at the rear ...
And I support the idea having a possibility to cool the second compartment as well would be great. Overall it's a good product and I really like the design but there is surely room for some improvement.
Reply With Quote


  #7  
Old 01-20-2020, 03:44 PM
slogan19 slogan19 is offline
Registered User
 
Join Date: Nov 2019
Posts: 11
POST ID # = 1032128
slogan19 Reputation: 10
Default

I had an issue with mine as well in a new build around Thanksgiving. I got the case early so I already had 8 fans in and everything wired up with a CoPro. I bench test and everything is fine with the components. I get everything installed, plug in the psu, everything lights up and then goes dead. Hit the power button, nothing. I made sure the case panel was wired up correctly to the motherboard, still nothing. I disconnect the case wires from the motherboard, push the on button on the motherboard and it works flawlessly. The only possibility then is the power button on the case is bad. I opened a ticket and was sent a new one a few days later.

Side note there...I asked support if there was an installation procedure and was told "just screw it in". Well, when it arrives I discover that it mounts from the top, I assumed from their short and sweet answer that it mounted from inside the rear compartment. So, just screwing it in first requires removing the entire top panel which requires removing the top glass and even then the top panel has a flange that slides under the front panel so I had to pry it loose at the top as well. After that, it was indeed as simple as screwing it in.

Other than the control panel, the case was in perfect condition and purchased from Newegg.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.