The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-12-2020, 11:27 PM
Swurv Swurv is offline
Registered User
Swurv's PC Specs
 
Join Date: Jan 2020
Posts: 1
POST ID # = 1031140
Swurv Reputation: 10
Default RM1000x won't start

Just bought a RM1000x for my new setup. Everything seems to be wired correctly, but when i push the power button i hear a quick screetch sound from the power supply followed by nothing else. Is this standard? DoA PSU? Please help!
Reply With Quote


  #2  
Old 01-13-2020, 03:35 PM
Corsair StormShadow's Avatar
Corsair StormShadow Corsair StormShadow is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 615
POST ID # = 1031222
Corsair StormShadow Reputation: 10
Default

Sorry to hear that, but it may be too early to pin it on the PSU.

If you haven't already, please try the following:

1. Use a single module of memory at a time and see if the system start.

2. Check for any debug LED code if your motherboard has one and reference the manual for the meaning of said code.

3. Make sure you have connected everything correctly.

It may sounds basic, but we have to be sure and I have to start somewhere.

Thanks.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.