The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-21-2010, 05:42 PM
digitalfreak digitalfreak is offline
Registered User
 
Join Date: Feb 2005
Posts: 5
POST ID # = 472642
digitalfreak Reputation: 10
Default HS1 broke already!

Just got my HS1 last night and used them a bit. Put them on when I got home today and the freaking ear piece fell off! Looks like the screws fell out, or were never there in the first place. Opened a case with tech support. I better get a new pair back and not some refurb considering these are less than 24 hours old.
Reply With Quote


  #2  
Old 11-04-2010, 03:23 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,268
POST ID # = 475022
RAM GUY Reputation: 10
Default

Sorry about that, did you get the RMA to replace them or is the reseller going to replace them for you? If not please post the case number and I will make sure our customer service helps you right away.
__________________
Support accounts and tickets can be created at https://support.corsair.com.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.