The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-02-2018, 07:13 PM
coltslaughter coltslaughter is offline
Registered User
 
Join Date: Feb 2018
Posts: 2
POST ID # = 938763
coltslaughter Reputation: 10
Default K63 & Dark Core RGB Wireless Issues

I just got the K63 wireless keyboard and dark core rgb mouse. I am having the below issues. Does anyone know how to fix them? I have updated to the latest CUE software and keyboard/mice firmware. I am using Windows 10 latest update. The two wireless dongles are plugged into an amazonbasics usb 2.0 hub, which is plugged into the usb 2.0 port on my motherboard. The hub with the dingles is about 1 ft from where I am sitting in direct sight of the mouse and keyboard. I have also tried plugging the dongles directly into the computer, which did not improve the issues.

1. When playing a game and holding "W" to move forward, my character will constantly stop moving and I have to depress "W" and push it again to continue moving forward.

2. The mouse will randomly stutter when moving as if it does not have a good connection.
Reply With Quote


  #2  
Old 02-02-2018, 08:05 PM
Shinken1 Shinken1 is offline
Registered User
Shinken1's PC Specs
 
Join Date: Feb 2018
Location: Manchester UK
Posts: 14
POST ID # = 938773
Shinken1 Reputation: 10
Default

My K63 Wireless acted a bit stuttery in my USB 2.0 port.
Since I put it into my 3.0 port it's been beautifully fine
Reply With Quote


  #3  
Old 02-02-2018, 08:18 PM
TheSlimShaney TheSlimShaney is offline
Registered User
TheSlimShaney's PC Specs
 
Join Date: Jun 2017
Posts: 3
POST ID # = 938776
TheSlimShaney Reputation: 10
Default

OS: Windows 10 1709
Hardware: Dark Core RGB, K63 Wireless
Latest CUE, latest firmware for both devices

I have the same exact issue. I happened to be looking at the Global Settings in CUE, and noticed whenever the issue happened, a (yellow I think?) exclamation mark would appear next to the keyboard icon. I believe that's the device not detected icon. So it seems something is causing the device to quickly be disconnected / not detected, required the user to release and repress the key they were pressing before. A computer reboot fixed the problem, but the issue reappeared a little after. I moved the dongles to USB 3 ports and will see if I still get the issue.

Let me know if I can do any testing to help root cause or test firmware.

Last edited by TheSlimShaney; 02-02-2018 at 09:41 PM.
Reply With Quote


  #4  
Old 02-02-2018, 10:50 PM
TheSlimShaney TheSlimShaney is offline
Registered User
TheSlimShaney's PC Specs
 
Join Date: Jun 2017
Posts: 3
POST ID # = 938791
TheSlimShaney Reputation: 10
Default

Here's a gif of the issue happening https://gfycat.com/ReliableScentedLeonberger
Reply With Quote


  #5  
Old 02-02-2018, 11:32 PM
HiImSteve HiImSteve is offline
Registered User
HiImSteve's PC Specs
 
Join Date: Feb 2018
Posts: 2
POST ID # = 938795
HiImSteve Reputation: 10
Default

Exact same issues on my end. Own both the K63 wireless and the Dark Core RGB. Nothing but problems. Firmware up to date. I've done everything I can think of in my settings. Nothing works. Just disconnects constantly when I'm gaming. I'll be going then it just stops for a split second and I have to push again to move. Also notice the yellow caution sign in CUE. It'll pop on for a second then go back just like the GIF that was posted above. Really disappointed.
Reply With Quote


  #6  
Old 02-02-2018, 11:34 PM
GreenGhost21 GreenGhost21 is offline
Registered User
 
Join Date: Jan 2016
Posts: 5
POST ID # = 938797
GreenGhost21 Reputation: 10
Default

I just wanted to, once again, add my two cents, and say that I've been experiencing the connection-esque issue with my Dark Core RGB (The cursor jumping around like it's having connection issues).
Reply With Quote


  #7  
Old 02-03-2018, 01:49 AM
TheSlimShaney TheSlimShaney is offline
Registered User
TheSlimShaney's PC Specs
 
Join Date: Jun 2017
Posts: 3
POST ID # = 938810
TheSlimShaney Reputation: 10
Default

Quote:
Originally Posted by HiImSteve View Post
Exact same issues on my end. Own both the K63 wireless and the Dark Core RGB. Nothing but problems. Firmware up to date. I've done everything I can think of in my settings. Nothing works. Just disconnects constantly when I'm gaming. I'll be going then it just stops for a split second and I have to push again to move. Also notice the yellow caution sign in CUE. It'll pop on for a second then go back just like the GIF that was posted above. Really disappointed.
seems like a temporary work around is to disconnect and recoonect the dongle when the connection issues happen. I put mine on the usb cord it came with and at least it's usable for 10-20 mins for me. Super annoying though.
Reply With Quote


  #8  
Old 02-04-2018, 04:25 AM
ncampos976 ncampos976 is offline
Registered User
 
Join Date: Jan 2018
Posts: 11
POST ID # = 938963
ncampos976 Reputation: 10
Default

i have a ton of problems with my k63 and dark core problems, both wireless, when both running wireless, they conflict with each other, and constantly disconnect
Reply With Quote


  #9  
Old 02-04-2018, 07:45 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 922
POST ID # = 939104
Corsair Nick Reputation: 39
Default

For those of you with issues, which firmware version are you on for K63 and Dark Core? Make sure to connect via USB 3.0 for the best performance.
Reply With Quote


  #10  
Old 02-05-2018, 12:20 PM
coltslaughter coltslaughter is offline
Registered User
 
Join Date: Feb 2018
Posts: 2
POST ID # = 939152
coltslaughter Reputation: 10
Default

Quote:
Originally Posted by Corsair Nick View Post
For those of you with issues, which firmware version are you on for K63 and Dark Core? Make sure to connect via USB 3.0 for the best performance.
I am using the latest firmware. I have the same issue on usb 2.0 and 3.0.
Reply With Quote


  #11  
Old 02-05-2018, 12:57 PM
haszek haszek is offline
Registered User
 
Join Date: Jan 2018
Posts: 9
POST ID # = 939158
haszek Reputation: 10
Default

I have same connection issues with my keyboard, only disconnecting usb receiver helps to find keyboard again. Latest firmware and CUE.

Does this keyboard have any hibernation mode when not in use? I thought battery would last for weeks if you are not using it while mine lasts 4 days (backlight off and not using it). Seems very poor :/
Reply With Quote


  #12  
Old 02-05-2018, 07:56 PM
HiImSteve HiImSteve is offline
Registered User
HiImSteve's PC Specs
 
Join Date: Feb 2018
Posts: 2
POST ID # = 939243
HiImSteve Reputation: 10
Default

Quote:
Originally Posted by ncampos976 View Post
i have a ton of problems with my k63 and dark core problems, both wireless, when both running wireless, they conflict with each other, and constantly disconnect
I returned my Dark Core RGB and kept the lapboard + K63 because I like them so much. Picked up the G903 and I've had no issue with either of them since. I have a feeling the 2.4 receivers were interfering with each other.
Reply With Quote


  #13  
Old 02-07-2018, 10:51 AM
haszek haszek is offline
Registered User
 
Join Date: Jan 2018
Posts: 9
POST ID # = 939557
haszek Reputation: 10
Default

Almost every time I start my PC I have to unplug/plug the receiver as it doesn't see the keyboard. Also charged battery on Sunday afternoon, 3 days later (used it maybe for 5hrs since), red battery light...

It's really good product, nice to use, so it's a shame it's got those problems, overall I wouldn't recommend it to anyone, unless software can fix it.
Reply With Quote


  #14  
Old 02-07-2018, 02:57 PM
Corsair Michael's Avatar
Corsair Michael Corsair Michael is offline
Corsair Employee
 
Join Date: Feb 2018
Posts: 21
POST ID # = 939589
Corsair Michael Reputation: 10
Default

Hi Everyone,

We're working on getting a blog post put up to help everyone ensure the best wireless connectivity, but in the meantime I can share with you some of that content below:

Quote:
The for the best ultra-fast wireless performance, CORSAIR recommends positioning the USB wireless receiver as close to the product as possible by plugging it into:

1. A front panel USB port on your desktop system
2. The USB charging / data cable via the USB cable adapter
3. A nearby USB pass-through port (for example on MM1000)

Moving the USB wireless receiver away from other USB wireless devices, wireless networking equipment, or USB storage devices (such as flash drives) can also improve wireless performance.
Regarding sleep/hibernation and battery life, both products feature a power switch and are meant to be turned off when not in-use for long periods of time. They do have states to conserve power, but they are also complex, robust, and responsive high-performance devices akin to their wired counter-parts.

Thanks!
Reply With Quote


  #15  
Old 02-07-2018, 05:36 PM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 9,220
POST ID # = 939606
c-attack c-attack Reputation: 107
Default

Quote:
Originally Posted by Corsair Michael View Post
Regarding sleep/hibernation and battery life, both products feature a power switch and are meant to be turned off when not in-use for long periods of time. They do have states to conserve power, but they are also complex, robust, and responsive high-performance devices akin to their wired counter-parts.
Can you provide an approximate range of how many hours we should be getting per charge (Dark Core)? I am concerned mine goes from a high to low battery state in 3-4 hours with a 15 minute sleep timer enabled.

Is there a difference between the "sleep" state of the mouse and full off? I don't necessarily mind switching the mouse off, but trying to flip that switch once the PC has been put to sleep without making it is not all that easy.

Presumably power saving mode reduces polling rate and LED brightness, however this does not seem to be explained anywhere.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.