The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-02-2010, 08:52 AM
_LarZen_ _LarZen_ is offline
Registered User
 
Join Date: Oct 2010
Posts: 2
POST ID # = 469288
_LarZen_ Reputation: 10
Default Need some help with setup

Just got my HS1 today and im realy happy with the quality and sound from it! Thanks Corsair!

But I have some questions, I play World of Warcraft and im woundering how many soundchannels I should sett it to in the Corsais HS1 USB Headset program, should I have it on stereo or in 7.1?

Kinda confusing...but then again im a noob at these things.

Hope someone can help explain a little, and again thanks to Corsair for making a realy nice headset. It's my first "expensive" headset and im realy realy pleased with it :)
Reply With Quote


  #2  
Old 10-02-2010, 11:47 AM
_LarZen_ _LarZen_ is offline
Registered User
 
Join Date: Oct 2010
Posts: 2
POST ID # = 469296
_LarZen_ Reputation: 10
Default

Im alsow getting a slight echo from voices in movies,games and voice chat that is a little irritating and should not be there...strange.
Reply With Quote


  #3  
Old 10-02-2010, 03:17 PM
roman59 roman59 is offline
Registered User
roman59's PC Specs
 
Join Date: Sep 2009
Posts: 33
POST ID # = 469327
roman59 Reputation: 10
Default

Hey there took delivery of the Hs1 last week, great headset as well.

Yes I am a wow addict, tried it in wow on 5.1 & also 7.1 both work really well & I suppose there really is no actual definate sound setting unlike Starcraft 2 where you have the 7.1 sound option in the games menu.

Play around with it and use which sounds the best to you :)

Hope this helps.
Reply With Quote


  #4  
Old 10-19-2010, 11:39 PM
Cupajava Cupajava is offline
Registered User
 
Join Date: Oct 2010
Posts: 4
POST ID # = 472315
Cupajava Reputation: 10
Default

Quote:
Originally Posted by _LarZen_ View Post
Im alsow getting a slight echo from voices in movies,games and voice chat that is a little irritating and should not be there...strange.
Larzen, Just picked these up a few days ago and love them. To remove the echo, click on the driver in the tray and in the mic setting, uncheck Monitoring. See if that helps.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.