The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software > iCUE SLIPSTREAM Open Beta

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 05-14-2020, 10:15 AM
wurstmeister wurstmeister is offline
Registered User
 
Join Date: Apr 2020
Posts: 2
POST ID # = 1046174
wurstmeister Reputation: 10
Default experience with Beta 3.28.73

After no news from corsair since march 13,
we were blessed with a new version of the ICUE beta.
Having issue since i decided to install the beta in march i jump on it and cross my finger in the hope that it will solve the same problem we all have with the virtuoso.

It was to my surprise to discover that nothing changed, not the slightest.
No improvement about the disconnection issue after getting the headset off of sleep, no improvement about random disconnection, and ,what i thought was THE feature that will be in this version, no feature to rollback the virtuoso dongle to the non beta firmware.

Why corsair? at least put the manipulation to do on this forum if you can't implement it in this version, even in command line.

i'm sick of telling my clients everyday, several time a day "sorry i have to reinstall my headset".

I fell trapped in this beta, and the fact Corsair didn't care answering us for the 2 past months doesn't help change that feeling.

I hope we won't have to wait another 2 month for this to be improve and that communication will start again between Corsair and the desperate Corsair's fan that we are.

Best regards
Reply With Quote
  #2  
Old 05-14-2020, 12:41 PM
Xploder Xploder is offline
Registered User
Xploder's PC Specs
 
Join Date: Jan 2020
Posts: 14
POST ID # = 1046203
Xploder Reputation: 10
Default Beta 3.28.73 feedback, using for 2 days now...

The new beta seems OK in the beginning. I use the slipstrem multi audio dongle with my Virtuoso SE and the Harpoon RGB wireless mouse.

The problem with the last beta from march 13th was that my Harpoon just return to Rainbow default settings when waking up from sleep and my Virtuoso was not recognized half of the time by iCUE. I must restart iCUE to see my Virtuoso again. To bring back the Harpoon in iCUE, I had to restart Windows !!

After testing the new beta 3.28.73, the Virtuoso seems to work everytime, but the Harpoon is not recognize by iCUE when waking sleep. This time, to make it works, I restart iCUE and the Harpoon is now available.

A new issue is affecting me that was not there before with last beta :
iCUE randomly closed for no reason, I have to re-open iCUE many times in 2 days only.

Corsair, this is very frustrating ! We put money and money on great products, but the software is not stable at all. Please help us !!!
Reply With Quote
  #3  
Old 05-16-2020, 09:19 PM
TwinkiesEJ TwinkiesEJ is offline
Registered User
 
Join Date: May 2020
Posts: 1
POST ID # = 1046578
TwinkiesEJ Reputation: 10
Default

My virtuoso SE and Ironclaw wireless doesn't get recognized when waking from sleep. I have to restart icue just to see them again in the options
Reply With Quote
  #4  
Old 05-17-2020, 11:00 AM
samusfett samusfett is offline
Registered User
 
Join Date: Apr 2020
Posts: 7
POST ID # = 1046620
samusfett Reputation: 10
Default

It's an absolute joke. Nothing has been fixed, and seems like it is even worse. Seemed fine at first but now my headset just constantly disconnects and reconnects every 20s or so. Nothing fixes it. iCue restart, Windows restart, iCue reinstall, nothing. My headset is completely unusable wireless. Corsair support refuses to help at all and just refers me to this forum and says to ask for help from employees here, which is an absolute joke because Corsair James doesn't reply to anyone or offer any help at all.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.