The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-31-2017, 10:34 AM
pinkpantiezz pinkpantiezz is offline
Registered User
 
Join Date: Aug 2017
Posts: 2
POST ID # = 918388
pinkpantiezz Reputation: 10
Default Corsair Scimitar PRO flashing white/pink

Hello people of the internet. I received a new Scimitar today because the old one was all choppy and a nightmare to play with. I plugged it in and it started flashing white/pink and the Scimitar is greyed out in CUE. I've reinstalled CUE twice without success. Tried unplugging and plugging it back in, changing USB ports and updating drivers in CUE and Device manager but nothing has changed.

Any help would be appreciated I really like this mouse when it works.
Reply With Quote


  #2  
Old 09-01-2017, 08:44 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,342
POST ID # = 918570
Toasted Toasted Reputation: 108
Default

Try resetting the mouse.
Unplug the mouse, hold both the left and right click buttons down while plugging the mouse in.

If that does not help, Put in a support ticket with instructions of hard reset.
https://support.corsair.com/
Reply With Quote


  #3  
Old 09-01-2017, 11:10 AM
pinkpantiezz pinkpantiezz is offline
Registered User
 
Join Date: Aug 2017
Posts: 2
POST ID # = 918580
pinkpantiezz Reputation: 10
Default

Quote:
Originally Posted by Toasted View Post
Try resetting the mouse.
Unplug the mouse, hold both the left and right click buttons down while plugging the mouse in.

If that does not help, Put in a support ticket with instructions of hard reset.
https://support.corsair.com/
Hi. Thanks for your reply. That didn't work so i sent a ticket to corsair.

just a heads up to anyone else having problems with the Scimitar Pro:

Please Note: For the Scimitar PRO RGB, this process is slightly different:

Unplug the mouse
With the mouse unplugged, hold down the left and right click.
While holding down the left and right click, plug the mouse back into the computer.
Hold the left and right click down until the mouse begins to flash.
Unplug the mouse and plug it back in.
Reply With Quote


  #4  
Old 02-11-2018, 12:50 AM
bradybil85 bradybil85 is offline
Registered User
 
Join Date: Feb 2018
Posts: 1
POST ID # = 940069
bradybil85 Reputation: 10
Default Soft-reset

I have tried both soft-reset methods and neither work for my scimitar. Any other suggestions to fix the pink/white flashing issue?
Reply With Quote


  #5  
Old 02-11-2018, 06:38 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,342
POST ID # = 940102
Toasted Toasted Reputation: 108
Default

Put in a support ticket with Corsair if you have not done so already. It's possible the LED is faulty.

https://support.corsair.com/
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.