The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-07-2016, 05:25 PM
Hostage83 Hostage83 is offline
Registered User
Hostage83's PC Specs
 
Join Date: Feb 2016
Posts: 4
POST ID # = 861460
Hostage83 Reputation: 10
Default Mx Brown (red leds) leds dying?

I have a problem with my k70 vengeance keyboard. I don't have the corsair software installed.

https://vid.me/p2MV

This also happens with the slash key on the numpad. The led goes out and I have to tap it to get it working again. This happens quite a lot.

I have this keyboard for 6 months now. Is it faulty?
Reply With Quote


  #2  
Old 07-07-2016, 08:50 PM
Corsair Henry's Avatar
Corsair Henry Corsair Henry is offline
Corsair Employee
Corsair Henry's PC Specs
 
Join Date: Oct 2013
Location: Corsair HQ
Posts: 1,403
POST ID # = 861479
Corsair Henry Reputation: 14
Default

It looks like a faulty LED to me. Go ahead and submit a RMA so we can replace this unit for you.
Reply With Quote


  #3  
Old 07-08-2016, 08:09 PM
Proffo Proffo is offline
Registered User
 
Join Date: Jan 2015
Posts: 303
POST ID # = 861593
Proffo Reputation: 8
Default

Quote:
Originally Posted by Corsair Henry View Post
It looks like a faulty LED to me. Go ahead and submit a RMA so we can replace this unit for you.
Looks like a bad solder joint or cracked PCB track to me. I don't think LEDs usually fail like that (intermittent).
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.