The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-18-2017, 06:52 PM
Truckfan Truckfan is offline
Registered User
 
Join Date: Jan 2017
Posts: 5
POST ID # = 912330
Truckfan Reputation: 10
Question Upgraded to 4.8.0.82 Link - Repeatably lose H80iGT Cooler Instrumentation Data

Windows 7 Pro x64
Corsair H80iGT Cooler
Corsair HX850i Power Supply
Corsair Link 4.8.0.82
Corsair USBXp Driver - 3.3.0.0 (Date: 7/4/2010)
Motherboard: Asus X99-A Revision: 1.xx (AMI BIOS: 2101)
CPU: Intel i-5820k CPU

Upgraded to 4.8.0.82 Link - Repeatably and consistently eventually soon lose H80iGT Cooler Instrumentation Data to Link - No errors in Device Manager for H80iGT Cooler driver

I can rely on that within a day or three that I will lose communication/connectivity from Link to/from my H80iGT cooler. This has happened back through many versions of Link, and has just been something I have rebooted system each time for a couple of years. And other times, to get a temporary resolution without having to reboot every time to fix, I would just uninstall (not checking the box "Remove Driver") the Corsair H80iGT USB driver from "Device Manager" under "Universal Serial Bus Controllers", and get temporary restoration of communication.

But I noticed at the last upgrade of Link 4.8 the USB driver had changed from an Asetek OEM driver with the descriptive name of "Corsair Hydro Series 7289 USB" to now "Corsair USBXp Driver" with Corsair as the driver manufacture and a version of 3.3.0.0. So I thought maybe my long-standing issues of losing the connectivity between Link and the H80iGT would be over. Well, no such luck. The newly installed USB driver seems to be an older date than the Asetek driver of before.

If it doesn't just stop working on it's own after a few days since last boot, I can also plug in a standard USB device to any USB port and it might stop the communication between Link and the H80iGT cooler. No errors indicated anywhere though.

I am a 28 year IT Senior Network and PC administrator, and so I can tell you that my system is very healthy. No dings in Device Manager. All drivers and current and system is up to date. No issues with system whatsoever besides this annoying need to reboot or un-install and re-install USB driver for H80iGT.

Is there any solution other than what I've already tried of removing and re-installing Link to keep this USB communication working for longer than 3 or so days?

Thanks,
TruckFan
Reply With Quote


  #2  
Old 07-29-2017, 03:36 AM
kampers kampers is offline
Registered User
kampers's PC Specs
 
Join Date: Jul 2017
Location: Norge
Posts: 6
POST ID # = 913758
kampers Reputation: 10
Default

Hello.

install Corsair LINK Installer v4.6.0.86 and try. Thats help me in my H115i.
Reply With Quote


  #3  
Old 07-29-2017, 10:14 AM
gato gato is offline
Registered User
gato's PC Specs
 
Join Date: May 2017
Posts: 5
POST ID # = 913822
gato Reputation: 10
Default Second installing 4.6.0.86

I gave up trying to get the latest CL software to work properly and reverted to 4.6.0.86. Things are stable now.

Corsair software development is incompetent, mediocre and probably does no regression testing. This is their software working with their own hardware and they can't get it right. Who has time to spend it in forums?
Reply With Quote


1 members found this post helpful.
  #4  
Old 07-30-2017, 11:56 AM
Truckfan Truckfan is offline
Registered User
 
Join Date: Jan 2017
Posts: 5
POST ID # = 913973
Truckfan Reputation: 10
Default

Thanks to you both. I am trying out 4.6.0.86.
TruckFan
Reply With Quote


  #5  
Old 08-01-2017, 05:13 PM
Truckfan Truckfan is offline
Registered User
 
Join Date: Jan 2017
Posts: 5
POST ID # = 914234
Truckfan Reputation: 10
Default

4.6.0.86 has already shown me much better stability in just the two days I've been using it.
Thank you.
TruckFan
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.