The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-30-2020, 02:17 PM
Specter_D03 Specter_D03 is offline
Registered User
 
Join Date: Jul 2020
Posts: 1
POST ID # = 1055937
Specter_D03 Reputation: 10
Default Please help me fix my ICUE

Hello,

So I have the K90, Scimitar, Polaris, St100 and Void pro..

All require Icue in order to function smoothly.. But Icue is not working on my laptop anymore. When I try to start it up, it show the main screen for 2-5 seconds then crashes.

I have tried to stop the service in task manager.
I uninstalled it and then reinstalled it.

I even formatted my hard drive and did a clean windows install.

I downloaded a fresh version of Icue of the corsair website. Yet after all that, the same problem would persist...

This started happening day before yesterday when I updated ICUE's firmware. Ever since then it refuses to load.

I cannot use my scimitar side keys, my sound is terrible without the ST100..
My void pro hates discord and the keyboard is soo sluggish...

Without ICUE, I cannot use my peripherals correctly. I really need it to work so I can use my devices.

Is anyone else having this issue or maybe you have an idea for a fix?
Reply With Quote
Reply

Tags
icue crashing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.