The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #91  
Old 10-27-2017, 04:14 PM
Catalonia Catalonia is offline
Registered User
Catalonia's PC Specs
 
Join Date: Jan 2017
Posts: 25
POST ID # = 924706
Catalonia Reputation: 10
Default

Seems to be working fine.

W10 64 Fall Creators.

H115i + AX1500i



I had the previous "latest" version having installed the old drivers manually. By installing this new version does the drivers get updated too?

Thank you
Reply With Quote


  #92  
Old 10-27-2017, 04:23 PM
BobT36 BobT36 is offline
Registered User
 
Join Date: Oct 2017
Posts: 26
POST ID # = 924707
BobT36 Reputation: 10
Default

Yeah as a note, I didn't install any older versions (besides trying it with the previous latest, that didn't work), so this was completely fresh.
Reply With Quote


  #93  
Old 10-31-2017, 11:17 PM
MalakaGuy MalakaGuy is offline
Registered User
MalakaGuy's PC Specs
 
Join Date: Oct 2017
Posts: 4
POST ID # = 925064
MalakaGuy Reputation: 10
Default

I have a older version,if i let corsair link update to the newest version,will it mess up the settings or something else?
Reply With Quote


  #94  
Old 11-01-2017, 12:11 PM
Corsair Dustin's Avatar
Corsair Dustin Corsair Dustin is offline
Corsair Employee
Corsair Dustin's PC Specs
 
Join Date: Oct 2013
Posts: 4,100
POST ID # = 925110
Corsair Dustin Reputation: 41
Default

It depends on the version. I wouldn't expect it to, but it is possible that you may have to fix some of your settings after the update.
__________________
Corsair DIY & Gaming Systems Architect
Product Manager for Cooling


Please do not send private messages requesting tech support or trouble shooting. You can create a thread and let the solution to your issue be visible to everyone, or alternatively, work directly with tech support by contacting them here.
Reply With Quote


  #95  
Old 11-09-2017, 02:45 PM
TevleGnirheg's Avatar
TevleGnirheg TevleGnirheg is offline
Registered User
TevleGnirheg's PC Specs
 
Join Date: Sep 2017
Posts: 32
POST ID # = 925827
TevleGnirheg Reputation: 10
Default

I rolled my machine back to prior to installing any Corsair Link software. Thereafter I was lucky to be in time to get my hands on the new CL version 4.9.1.23 and so I installed this and the USBxp drivers installed without a problem. No errors about unsigned software.

My system has a super user (Administrator account) and a few non administrator accounts. I then picked up an error about System.UnauthorizedAccessException.

To resolve this I did the following:
1. Logon with administrator rights
2. Go to the directory where CorsairLink4 is installed (C:\Program Files (x86)\CorsairLink4)
3. Right click on CorsairLink4.exe
4. Click the Compatibility tab
5. Place a check mark in "Run this program as an Administrator"

Problem solved on my system. Whenever I click on CorsairLink4 I get prompted to enter an administrator password and CL starts up.

Check the following posting to find out how I rectify the incorrect number of fans and temperature sensors:
http://forum.corsair.com/forums/show...d=1#post925823

Luckily resolving the incorrect numbering of CPU cores is easy, just click on the CPU core of your choice and change the number after the # to the correct value and click on apply.

I also tried a few runs of installing 4.8.0.82 and 4.7.0.77. 4.7.0.77 installs the unsigned drivers as well as some other software. What I can vouch for is that after this I was able to install 4.9.1.23 and it replaces all the drivers and remove the extraneous software item successfully.

Last edited by TevleGnirheg; 11-09-2017 at 02:52 PM.
Reply With Quote


  #96  
Old 03-01-2018, 12:27 AM
cuda12 cuda12 is offline
Registered User
cuda12's PC Specs
 
Join Date: Feb 2018
Posts: 10
POST ID # = 942698
cuda12 Reputation: 10
Default

Quote:
Originally Posted by linxeye View Post
Hey there got the update for Link with 4.9.123. Driver was upgraded on the flight and worked great until I reboot. I still have Corsair USBxp driver in devman with error code 52. I can see though the driver is now signed as of july 2017.

No fix for me, no control of H100i v2 from Corsair Link. No kidding :(
Same here :(
Reply With Quote


  #97  
Old 03-01-2018, 10:38 AM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,523
POST ID # = 942747
DevBiker Reputation: 88
Default

Quote:
Originally Posted by cuda12 View Post
Same here :(
Have you tried going in to Device Manager and enabling the driver there? See the Cooler FAQ linked in my signature.
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Reply With Quote


  #98  
Old 05-20-2018, 05:24 PM
cmkeddy88 cmkeddy88 is offline
Registered User
cmkeddy88's PC Specs
 
Join Date: Apr 2018
Posts: 2
POST ID # = 955452
cmkeddy88 Reputation: 10
Default

My driver doesn't show up at all, I have an H100i, running Windows 10. I have tried reinstalling, installing older versions, nothing seems to work.

Last edited by cmkeddy88; 05-20-2018 at 05:29 PM.
Reply With Quote


  #99  
Old 05-21-2018, 03:14 PM
sddjd sddjd is offline
Registered User
sddjd's PC Specs
 
Join Date: May 2018
Posts: 3
POST ID # = 955595
sddjd Reputation: 10
Default

Quote:
Originally Posted by DevBiker View Post
Have you tried going in to Device Manager and enabling the driver there? See the Cooler FAQ linked in my signature.
Go to Windows Device Manager. Expand “Universal Serial Bus controllers” and look for “Corsair USBXp Driver”. If it’s disabled, enable it. If it’s enabled, disable it and then re-enabled it.

If we're missing the driver entirely what steps are required to install it? The last two versions of Link failed to install the driver, so we're dead in the water. Thanks.
Reply With Quote


  #100  
Old 04-27-2019, 09:37 AM
Gronar Gronar is offline
Registered User
Gronar's PC Specs
 
Join Date: Mar 2019
Location: Round Rock, Tejas
Posts: 109
POST ID # = 1002727
Gronar Reputation: 10
Default

The rabbit hole led me to this. In devman under Universal Serial Bus controllers I have no entries labeled as "Corsair USBXp Driver". How do I get this installed?
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.