The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-20-2017, 06:30 PM
PacificMist PacificMist is offline
Registered User
PacificMist's PC Specs
 
Join Date: Jun 2017
Posts: 4
POST ID # = 908877
PacificMist Reputation: 10
Sad Corsair Link not showing my devices (possible USB problem?)

I was searching for a while on these forums for a solution before I decided that I need to start a new post. FYI I have tried the Regedit fix and it doesn't work. I think that it is a USB problem since it has an error in device manager. I saw an older post where Ray gave someone advice on how to use SIV to fix the error 43 problem. Currently, my SIV looks like this if someone could please help I would greatly appreciate it. Thank You
Reply With Quote


  #2  
Old 06-20-2017, 06:30 PM
PacificMist PacificMist is offline
Registered User
PacificMist's PC Specs
 
Join Date: Jun 2017
Posts: 4
POST ID # = 908878
PacificMist Reputation: 10
Default

it looks like you can't see my pictures but if you "Open in New Tab" them you should be able to see them.
Reply With Quote


  #3  
Old 06-20-2017, 07:00 PM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 908881
red-ray Reputation: 81
Angry I am not Corsair Support

See http://forum.corsair.com/forums/showthread.php?p=853900 for how to attach a file/screen image to a post.

After looking at the images I can't easily see I suspect if in Device Manager you disable and then enable the problem device it may start working again.

Failing that uninstall it, shut the system down, unplug it for two minutes, cross your fingers, throw salt over your sholder and then boot up the system.

It may help to know what device you have and I feel you need to use http://forum.corsair.com/forums/profile.php?do=extra to add more of your PC specs

If you wish to get instant support you should contact Corsair Support rather than e-mailing me and when referring to "an older post where Ray gave someone" you should link to it.

Quote:
Originally Posted by PacificMist View Post
While you may not be Corsair support you are very capable of fixing people's issue .
From bad to worse. If I help members I do this because I choose to and feel explicitly e-mailing me 2 minutes after posting is inappropriate.

Ignore lists and junk e-mail folders are good features.

Last edited by red-ray; 06-21-2017 at 07:44 AM. Reason: Seems to think I am Corsair Support then from From bad to worse
Reply With Quote


  #4  
Old 06-20-2017, 07:44 PM
PacificMist PacificMist is offline
Registered User
PacificMist's PC Specs
 
Join Date: Jun 2017
Posts: 4
POST ID # = 908883
PacificMist Reputation: 10
Default

I tried Enabling and Disabling it and you were right it didn't fix I am currently going to try uninstalling and shutting down. While you may not be Corsair support you are very capable of fixing people's issue .
Reply With Quote


  #5  
Old 06-20-2017, 08:07 PM
PacificMist PacificMist is offline
Registered User
PacificMist's PC Specs
 
Join Date: Jun 2017
Posts: 4
POST ID # = 908885
PacificMist Reputation: 10
Default

I think it worked. (See attached)
Thank you so much, Ray!
Attached Images
File Type: png ef286427176780de30b96fc8b7925dc4.png (247.0 KB, 384 views)
Reply With Quote


  #6  
Old 07-09-2019, 06:40 PM
Exsosus Exsosus is offline
Registered User
Exsosus's PC Specs
 
Join Date: May 2019
Location: Stockholm area, Sweden
Posts: 10
POST ID # = 1010713
Exsosus Reputation: 10
Default

Hi, everyone. After 3-months + with Corsair support the answer is simple.

Step 1: Run Winver in Run command.
Step 2: Uninstall iCue complete and if you have Link installed, that too.
Step 3: Restart Windows. (Yes I know its windows 10 but this is hardware related. Do it).
Step 4: Install Corsair Link 4.9.9.3 for Windows version 1809 OS Build 17753.557 or later.
Step 5: If you want iCue for your keyboard RGB and other accessories install that now.

You should have all devices showing in Corsair Link!

Enjoy.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.