The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-25-2017, 04:23 PM
Insaniq Insaniq is offline
Registered User
Insaniq's PC Specs
 
Join Date: Jan 2017
Posts: 2
POST ID # = 888383
Insaniq Reputation: 10
Default Corsair Link TM USB Dongle - (Code 28)

Hi, I have just built a new system and using Corsair H100iv2, Corsair AX860i, Dominator Platinum - cmd16gx4m2b3200c14
Corsair STRAFE keyboard and SABRE RGB LASER mouse
Headset Corsair H2100.

With that I have downloaded and installed:

Corsair Utility Engine (CUE) Software
Corsair LINK v4.3.0.154
Corsair Gaming H2100 2.0.37


Everything seems to work well, but I ended up in a reboot loop that I ready some are experiencing.
My device manager is showing "Corsair Link TM USB Dongle as a malfunctioned device
"
The drivers for this device are not installed. (Code 28)
There are no compatible drivers for this device.
"

And Corsair link suggests a reboot every time I start the system.
I have located the guides where one need to change registry settings but was not able to locate the mentioned USB device.

I have tried to switch USB headers, disabling the H100iv2 but nothing helps.

Please help.
Attached Images
File Type: png link.png (247.0 KB, 882 views)
Reply With Quote


  #2  
Old 01-25-2017, 04:44 PM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 888388
red-ray Reputation: 81
Idea I suspect the AX860i drivers are missing

The AX860i is missing from the CL4 [home] tab and I suspect you need to install it's driver.

I suspect the attached is what is missing.

The CL4 installer should have installed these, but I suspect it failed to.

It would be easier/possible to help more if you posted screen images rather than telling us what you recall they said.

Quote:
Originally Posted by Insaniq View Post
I have located the guides where one need to change registry settings but was not able to locate the mentioned USB device.
Specify the URL
Attached Files
File Type: zip AXi PSU Drivers.zip (176.2 KB, 1928 views)

Last edited by red-ray; 01-25-2017 at 04:48 PM.
Reply With Quote


  #3  
Old 01-25-2017, 05:20 PM
Insaniq Insaniq is offline
Registered User
Insaniq's PC Specs
 
Join Date: Jan 2017
Posts: 2
POST ID # = 888394
Insaniq Reputation: 10
Default

Thank you red-ray! It worked perfectly!
Reply With Quote


  #4  
Old 03-10-2017, 07:52 AM
emirati89 emirati89 is offline
Registered User
 
Join Date: Mar 2017
Posts: 1
POST ID # = 894557
emirati89 Reputation: 10
Default

I had same problem, now fixed.
Thank you.
Reply With Quote


  #5  
Old 03-11-2017, 08:18 PM
UlvAvformørkels UlvAvformørkels is offline
Registered User
 
Join Date: Mar 2017
Posts: 1
POST ID # = 894781
UlvAvformørkels Reputation: 10
Default cant get it to work

i have been trying to get the drivers (dongle for ax1200i) to install but i keep getting "publisher of an Authenticode signed catalog was not established as trusted". any help would be much appreciated.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.