View Single Post
  #3  
Old 08-11-2019, 10:59 AM
First Blood First Blood is offline
Registered User
First Blood's PC Specs
 
Join Date: Apr 2018
Posts: 11
POST ID # = 1014363
First Blood Reputation: 10
Default

**DO NOT USE CABLES FROM OTHER MANUFACTURES**
Iam sure many people know but sometimes mistakes happen and you might mix up the cables. Here is some real proof and my experience from testing this out what happens.

Reason why the 8pin EPS cable from AX1600i did not work with EVGA 1600 T2 psu even tho it fit perfectly is because the internal wiring is different. So the system would not power up and my EVGA T2 1600 just auto shut off to protect itself and the components. If this was some cheap psu without proper protection then it would have been very expensive lesson.

I tested the AX1600i 8PIN EPS/CPU(Type 4) cable on my other computer that has a AX1500i which uses type 3 cables and it works perfectly fine. So that rules out my assumption that something was wrong with this cable. But still there is possibility that the 24 pin atx cable is the issue because the psu does pass self test, only fails with red light once its plugged into any motherboard and I tested it on 3 different motherboards.

Corsair customer service determined that the psu is faulty and they will just RMA it. Thanks! I am still wondering why a brand new sealed, never used psu of this calibre quality that it passed factory manufacture quality control would be DOA. I still think the psu is fine but the 24 pin atx cable is faulty as this cable has built in capacitor that could be faulty.
Reply With Quote