View Single Post
  #1  
Old 09-25-2015, 11:07 AM
coordz coordz is offline
Registered User
 
Join Date: Sep 2015
Posts: 1
POST ID # = 810461
coordz Reputation: 10
Sad H80 fan stuck at max, then tried firmware reset, now dead :(

I decided to upgrade to some dual GTX 980 TI cards and in the process needed to change power supply. This involved unplugging my H80 molex and then replugging it in. After this switch, everything started up just fine but instead of the radiator fans on the H80 spinning up and then idling back down after boot they stayed at max.

Looking around the forums I found some threads with similar problems
http://forum.corsair.com/v2/showthread.php?t=97433
http://forum.corsair.com/v3/showthread.php?t=104745
so I tried doing a reset of the firmware.

The first time I did this reset, all worked fine and after the reset the fan speed became adjustable again. However, power cycling the system put the fans back up to max and unable to be changed via the button on the controller.

The second reset attempt led to control being restored to the button on the controller. However, after a number of presses to switch between fan settings, the fans completely switched off and all lights went out on the controller. Further presses of the button didn't help. (While doing this pressing I was monitoring the RPMs in the BIOS and then were around 2300 and then went to N/A when the fans died).

So far I've tried a number of power cycles, some resetting long presses and leaving the machine without power for a few hours. Each time after restarting I get a "CPU fan error" from the BIOS.

Restoring power after a few hours causes the fans to 'twitch' but then nothing. My current plan is to leave the machine without power for a few days and then try again......

Can anyone help me with this? It seems like the firmware in the H80 has got in a funny state and has decided not to work. Right now I just need to get the pump going again as I can always plug the fans into my mobo.

Thanks!
Reply With Quote