View Single Post
Old 06-17-2018, 05:14 AM
deltaminds deltaminds is offline
Registered User
deltaminds's PC Specs
Join Date: May 2018
Posts: 21
POST ID # = 959417
deltaminds Reputation: 10

Originally Posted by yaners02 View Post
Just unboxed these about an hour ago after getting off work. I turned them on, and plugged them into the PC to begin charging (per the manual's instructions). I downloaded the iCUE software, and disabled the RGB lighting. At this point, the headphones turned off, and won't turn back on.

I tried getting them out of the "bootloader" mode, but since they won't turn on or register in the iCUE software as being plugged in, I can't flash the firmware.

Windows detects the headphones just fine in the device manager as Corsair VOID Wireless Gaming Headset. I'm unsure of why they can't be turned on while plugged in...this seems like either a manufacturing defect, or simply a poorly designed product.

Any ideas on how I can get these to turn on/be usable again? The 5 minutes the sound worked they were great, but if there are firmware/software issues that render these unusable after such a short period of time, I think I'll have to return them.

I unplugged the wireless receiver and plugged in the headphones by themselved via the USB cable. They do register as the device associated with bootloader mode. HOWEVER, iCUE still DOES NOT recognize the headphones when plugged in sans the wireless receiver. If the wireless receiver is plugged in, the device appears in iCUE, but it says "disconnected."

Update 2: Called phone support. The fix was to hold down the mute button for 20 seconds. The headphones are once again functional!
Weird that the solution wasn't mention anywhere else, but atlast it is now fixed for you :)
Reply With Quote