View Single Post
  #13  
Old 06-21-2017, 11:38 PM
SpeedyV SpeedyV is offline
Registered User
SpeedyV's PC Specs
 
Join Date: Jan 2017
Posts: 419
POST ID # = 909032
SpeedyV Reputation: 41
Unhappy LED Problems

Well tonight did not go so well. Here is what happened.
  1. I unplugged the LED strip and gently separated the 2 halves of the strip. I used a temp controlled soldering iron and a solder removal hand pump to remove the solder on the +5vdc, Ground, and Data pads, then separated the strip into 2 halves.
  2. I soldered the three temporary twist and tape connections I made last night and cleaned up the wiring harness.
  3. I hot plugged the first 1/2 of the LED strip back into power and data (CLCP LED Port 2). It worked fine. I then unplugged the strip from power and data.
  4. I maneuvered the strip into the case where I wanted it. I had to do some flexing of the strip but tried to be gentle with it. Plugged it back into power and data. Here is where the problems begin. Only the first 2 LEDs would respond.These 2 LEDs would respond to color and pattern changes but nothing past the 2nd LED would work.
  5. I thought maybe the flexing was enough to break a connection between the 2nd and 3rd LED. I very carefully laid out the strip and touched up the connection points with the soldering iron. No change.
  6. Tried hot un-plugging and re-plugging power and data. Tried exiting and re-starting SIV. Tried power cycling the CLCP and LED Hub. Tried a full reboot. No change.
  7. I removed the strip and soldered the 2 halves of the strip back together. No change.
  8. I then separated the 2 halves again, and de-soldered where the wiring harness connects to the strip and soldered it to the 2nd half-strip. It worked!
  9. I tried gently and then more aggressively flexing the strip, thinking this particular LED strip must be very sensitive to flexing, and I broke a connection somewhere in the first half. The strip continued to work fine through the flexing.
  10. This time I installed the working LED strip where I wanted it while it was running. This required holding the strip in place with thin wire ties that I very gently pulled snug but not tight. The strip continued to work but then all of a sudden, just as I finished with the last wire tie, all of the LEDs except the first 14 went out.
  11. I tried flexing the strip some more. No change . I figured it's broken anyway so might as well flex it aggressively and see if more LEDs light up or go out. No change.
  12. I tried reversing the port on the CLCP - moved the LED Hub to CLCP LED Port 2 and put the LED strip on CLCP LED Port 1. The fan LEDs and the first 14 LEDs in the strip worked as expected.
  13. I put a volt meter on the +5vdc and Ground pins at the other end of the strip and measured +5vdc. The voltage was steady while shaking and flexing the strip. So +5vdc and ground are getting all the way to the other end of the strip with no sign of a shaky connection.
  14. I don't think there is any way for me to test the Data path integrity with a volt meter.
  15. So now as I give up for the night, half 1 only has the first 2 LEDs working and half 2 has the first 14 LEDs working.
  16. I thought about trying to touch up the Data pad between the 14th and 15th LED but when I did that on the first half (between LEDs 2 and 3) it made no difference.
  17. I am not sure if this particular LED strip is very sensitive to flexing. The LEDs are very close together so the strip is not very flexible. It's almost all LED. But aggressively shaking and flexing the area of LEDs 1 through 14 (which work) has not caused any change. The strip does not seem to mind being flexed.
  18. I tried a bunch of different modes and changed colors. The 1st 14 LEDs on the strip do everything they are supposed to do. From LED 15 on are dead.
  19. I only have connectors to hook up 1 strip at a time so it is not easy to switch back and forth, as I have to de-solder the wiring harness and then solder it onto the other strip to switch. I am going to figure out a way to allow me to connect to either end of either strip easily with what I have here.
  20. I don't know if I physically damaged both halves of the LED strip or if there is some sort of data problem. I know power and ground connections are good because I measured a steady 5vdc across those pads at the opposite end of the strip.
  21. I think I will try un-soldering the wire harness and then soldering it to the pads on the other end of the strip. I wonder if that would normally work - in a sequence, what determines which physical LED is which logical LED? Which end is "LED ONE"? If the 1st 15 LEDs work at that end, I think that would indicate a control problem instead of a electrical connection problem in the strip. Too late to do it tonight so it will have to wait until tomorrow night to try this.

Last edited by SpeedyV; 06-22-2017 at 12:47 AM.
Reply With Quote