View Single Post
  #4  
Old 09-04-2019, 07:59 AM
First Blood First Blood is offline
Registered User
First Blood's PC Specs
 
Join Date: Apr 2018
Posts: 11
POST ID # = 1016831
First Blood Reputation: 10
Thumbs up

Quote:
Originally Posted by bl4C View Post
Problem solved !

Corsair support asked me to check the pins of the 24pin connector, and it turned out that pin 4-5 were slightly "opened" … I closed the female pins a little more, and now it works fine :) (see 24pin.jpg)

This could have been a result of using the paperclip method to start up the PSU to test my water cooling loop without connecting anything else to the PSU.

So next time, I will be a little more careful about the pins :)
lol really just loose pins? thats good you didnt have to go through RMA process, like I did. Maybe that was my issue too since the psu pass selftest with flying colors but only failed once connected to a mobo and it would just attempt to turn on but quickly shut off. And there was power going into the mobo because all the led lights were on. Hahah after reading your post now I am almost certain it was broken 24 pin cable! I was even concluding that after diagnosing on 3 different computers! But never occurred to me to fully check for loose pins. wtf! lol maybe I did quickly but next time I will use a flashlight and check the pins thoroughly! Customer rep just told me to RMA it and not waste any more time on it, no one ever mentioned "possible loose pins".

I got the new psu yeseterday and it works! Next time I will remember to thoroughly check for any loose pins! Thanks for sharing!

Last edited by First Blood; 09-04-2019 at 08:07 AM.
Reply With Quote