View Single Post
  #37  
Old 12-16-2017, 01:04 PM
amurph0 amurph0 is offline
Registered User
 
Join Date: Aug 2016
Posts: 4
POST ID # = 930816
amurph0 Reputation: 10
Default

Quote:
Originally Posted by Corsair Dustin View Post
I'm sorry you've had such bad experiences with our hardware and products and I totally understand where you're coming from.

Unfortunately, the Commander Mini's firmware issues won't and actually can't be fixed. We don't control the firmware for Commander Mini and are at the mercy of the vendor. If the vendor decides they don't feel like updating the firmware for the product, we're SOL. This is actually why Commander PRO exists - we control the firmware on that product precisely so we can avoid the pitfalls that Commander Mini ran into.

And you're right. You shouldn't have to call the number. If anything, we should be calling you. If you have a ticket number, PM it to me and I can have one of our customer service representatives reach out to you specifically and try to get things straightened out. We're going into the weekend so it may not be immediate, but I can make sure someone gets back to you sometime within the next few days.

Since the Commander Mini itself is the issue, in your case I'd request a Commander PRO to replace the Mini and RGB PRO LED strips instead of the RGB strips you originally ordered. Tell the representative to contact Dustin Sklavos with questions.
Hi Dustin

It has been nearly two months since I first brought up this issue and after long delays of my ticket being ignored on the Corsair Support website, and having to contact live chat multiple times just to get someone to look at my ticket, I finally received the Corsair Commander PRO last week as a replacement for the Commander Mini that I sent for RMA.

There were no LED strips included with the Commander PRO, even though I was told specifically by customer support multiple times that the Corsair PRO RGB strips would be included.

Now, just a few days ago I received another package from Corsair. In it was a zip lock bag with two LED strips. No branding or anything. It looks like they just threw some old ones into a box and sent them.

And guess what. They aren't even the RGB Pro LEDs. So they don't work with the Commander PRO because the connector is different.

I don't think I'll even bother going to the effort of updating my ticket regarding it or contacting live chat. Because I doubt anything will be done by them to remedy it.

I don't think I'll even bother installing the Commander Pro now either after the experience I've had with Corsair support I think I'll just try and sell it on and buy an NZXT Hue+ instead, or try and use the built in ASUS Aura software on my motheboard. As for the LED strips, I think I'll just throw them in the bin.

This has been a total failure of customer support by Corsair, and I don't think I'll be buying anything else from Corsair in the future.


Last edited by amurph0; 12-18-2017 at 12:10 PM.
Reply With Quote