View Single Post
  #2  
Old 06-12-2017, 06:30 PM
ZeroFatal1ty ZeroFatal1ty is offline
Registered User
ZeroFatal1ty's PC Specs
 
Join Date: Jun 2017
Posts: 1
POST ID # = 907730
ZeroFatal1ty Reputation: 10
Default

Quote:
Originally Posted by cxmachi View Post
I am having an issue that is most definitely an issue with the K70 Lux RGB and how it interacts with the USB ports on this PC.

Whenever I plug in a USB device (be it a controller, a secondary mouse), Steam will freeze. The caps lock and num lock indicator on the keyboard will also not work anymore.

As soon as I set the polling switch on the keyboard to BIOS, then Steam unfreezes. When I set it back to

This is most definitely an issue with the keyboard as I have not had any of these issues prior to owning this keyboard. While you can say that it might be a compatibility issue with Steam, that's not really acceptable considering a gaming keyboard should at the very LEAST be working with Steam.

I've tried changing between USB ports, from USB 2.0 to 3.0 and back. Tried updating all the drivers and it's still the same issue. I've looked all over these forums and there is definitely quite a few of us experiencing the same issue.

Steps to Reproduce:
1. Start computer.
2. Notice that CUE has loaded up since my lights are showing RGB effects
3. Plug in a USB device like a controller or another mouse
4. Notice that Steam freezes and is unusable. ALSO notice that if you press Caps Lock or Numlock, the lights will not light up, no matter what you do.
5. Set polling switch to BIOS
6. Steam now unfreezes and is usable.
7. Set polling back to default. Caps lock and Numlock also now works again.
8. You can now unplug and replug USB devices without issue, but this only lasts for maybe 1 or 2 replugs. You have to go back to Step 1 again.

I don't want to have to do this workaround every single time. Note, I also just tested this and you can replace Steam with the Windows USB Game Controller screen. This keyboard is definitely causing USB conflicts and it's not just me.

Relevant specs:
Motherboard - Asus Maximus IX Hero
Keyboard - Corsair K70 RGB Lux

Attaching CUE log files as well


cxmachi, you are not alone.

I'm having the exact same issue with the same K70 RGB LUX and Maximus IX Formula. Sounds like a USB handling exception.

I already submitted a support ticket, so to spare the details I'll paste it here.... Lemme know if this is spot on.



Ticket Description:

Cue 2 and my K70 RGB LUX has issues when opening Steam and launching games (from other clients too). When Steam hangs, I can flip the polling-rate switch and it stops hanging. Steam, Need for speed 2015, Mass Effect Andromeda, Watchdogs, The Division, DOOM, Ghost Recon Wildlands, and others all hang on launch and close due to this issue. Hang time, appcrash, and timeout can last 30 seconds to 2 minutes.

This issue doesn't occur with K70 unplugged OR Cue 2 uninstalled. Everything loads instantaneously.

Steam and others function fine with another keyboard and Cue and the K70 performs fine without Cue installed.

This was with a clean OS, clean steam install, and clean CUE install with just drivers. All were latest versions, including motherboard BIOS. I've tried many USB configurations.

The problem seems to occur when CUE installs the "Virtual USB composite device" and "Corsair BUS." Then the keyboard has trouble with Steam/others.

I also have the Glaive, VOID Wireless, and Polaris mouse pad.

This link -> http://forum.corsair.com/v3/showthread.php?t=168442 - describes the problem identically.

Specs: Asus Maximus IX Formula, Intel i7 7700K, Corsair Vengeance RGB 32GB 3466Mhz, ASUS GTX1080ti OC, Samsung 960 Pro 1TB NMVe, Corsair HX1000i PSU.

BIOS Settings are all AUTO except CSM disabled. Legacy USB set to AUTO



Sound Familiar?
Reply With Quote