View Single Post
  #1  
Old 04-04-2018, 06:27 AM
crainger crainger is offline
Registered User
crainger's PC Specs
 
Join Date: Jun 2011
Location: Coffs Harbour, AU
Posts: 4
POST ID # = 948542
crainger Reputation: 10
Default Unable to update firmware in Glaive

So this has me stumped.

I have a Corsair Glaive that was on 1.03, CUE 2.23.40 reported a firmware update. When running the update it failed @ 0% and the mouse would disappear from CUE. Closing and reopening CUE brought it back.

I contacted support who had me soft reset the Glaive. Then place the mouse into bootloader mode and copy 1.03 across manually and reattempt the firmware update. This didn't work either.

My friend dropped by with her PC, running CUE 2.15.83. The mouse updated to 1.04 no problems! So seems the issue might be my PC.

My PC is a 8700K, MSI Z370 Gaming 5, Win 10 with a Corsair K95 Platinum also connected. The keyboard updates no problems. Just the mouse would not.

Anyone come across something like this before?

I also tried disabling USB legacy mode
Disconnecting all other USB devices

I didn't try disabling XHCI as I believe Skylake and up needs this enabled for USB to work at all.
I also haven't tried disabling MSI fast boot, as that only affects USB devices during boot.

Other than the firmware issue, the mouse works fine. I just don't want to have a problem, down the track where a firmware update is the fix.
Reply With Quote