View Single Post
  #8  
Old 03-22-2011, 05:49 PM
McMalakai McMalakai is offline
Registered User
McMalakai's PC Specs
 
Join Date: Oct 2009
Posts: 13
POST ID # = 494753
McMalakai Reputation: 10
Default

Quote:
Originally Posted by RAM GUY View Post
McMalakai, the blinking lights indicate that the HS1 is not using our driver. Can you uninstall the HS1 driver and then try re-installing it from this link:

http://www.corsair.com/media/cms/drivers/HS1_Setup.zip
Thanks, I sorta figured that one out. Was trying to MS drivers in testing.

I did get a new PCI USB 3.0 controller. It didn't make any appreciable difference.

HOWEVER....
I found something interesting. While trying the new USB controller, I put the Corsair drivers back on. After getting unacceptable results in my two tests ( TF2 in-game, and Ventrillo Codec: Speex 32KHz, 16 bit, 10 Q ) I decided to experiment with the "Enhancements" tab.

With the "Low Frequency Protection" enabled, and set to _ANY_ cutoff, everything "works". It's not perfect, I still get a lot of background hiss/noise, but people can understand. Also, and even better, the "Monitor" test in Ventrillo now reports integers ( instead of AbsZero, it gives a range starting from 0 ). So VOX activation can work now.

This is with nothing else change ( Advanced Tab left to defaults ). I even switched back to my normal USB ports.

BASICALLY, here's what I think is going on...

The microphone is almost too sensitive. Perhaps pure digital has a downside. The CODEC's have trouble with all the information. This "Low Frequency Protection" is eliminating part of the range of the mic, which allows these CODECs to better do their job.

I don't know if that's the case, but I can tell you the LFP allowed me to finally use my HS1's in actual competitive gaming. My mic doesn't not sound as perfect as my old analog mic, but it's close enough. I wish I could run some more filters on the mic. I think my old audio card had special filters for voice mic's to eliminate ambient noise and other extreme frequencies.

Maybe our problem is the HS1 mic is 'studio' quality, and we're used to dealing with a mics that functioned on a more limited range.

Either way, it should work better out of the box. Tweak the defaults in software, and by default enable these filters. Then provide a means to disable them for someone who wants full range ( or is dealing with a better codec ).
Reply With Quote