View Single Post
  #2  
Old 05-16-2017, 05:28 PM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 903472
red-ray Reputation: 81
Thumbs down PCH/ICH SMBus locking totally broken, no X79 MB + CPUs and LNP firmware update fails

  1. With CL 4.7.0.77 the PCH/ICH SMBus interlocking is totally broken .
    1. Below you can see only five of the six DIMMs were reported and one of the names was misread.
    2. SIV also detected the ICH10 SMBus controller registers had been changed when it was holding the Global\Access_SMBUS.HTP.Method named mutex so needed to do retries.
    3. The issue is far more likely to happen on systems with have DIMMs with MTS as other utilities (AIDA64+HWiNFO+SIV) are likely to be reading the SMBus of a regular basis.
    4. I am at a loss as to why Corsair failed to find this issue before CL 4.7.0.77 was released .
    5. As I found the same issues with CPUZ + HWM I contacted the CPUID SDK developers and worked with them to fix the bugs .
    6. Corsair, you need to ask for the fixed CPUID SDK and should make it available as a download .
    7. I also just noticed there two DIMMs called Temp #1 which is somewhat inappropriate.
    8. After working with the CPUID SDK developers on Tue 20-Jun-2017 I tested a 1.1.6.7 cpuidsdk.dll and using this CL 4.7.0.77 finally reported my system as it should, well almost, staring from Core #2 is rather poor and shows the Corsair testing is .
    9. Corsair would be wise to ensure the next CL4 release uses the 1.1.6.7 cpuidsdk.dll or later and I have made them aware of my view.
  2. CL 4.7.0.77 no longer lists my Motherboard and CPUs. Below are the [Home] tabs from CL 4.7.0.77 + CL 4.6.0.86 that clearly show this regression.
  3. The LNP 0.3.72 firmware update got stuck at 35%, see http://forum.corsair.com/forums/showthread.php?p=892389 for how I recovered from this.
  4. CL 4.7.0.77 also failed to display the CPUs and Disks on my Dell 490 when CL 4.6.0.86 did, see http://forum.corsair.com/forums/atta...0&d=1490084915.
  5. The memory title still also flashes between Hyundai Electronics and Qimonda.
  6. On my HP DL580 G5 CL 4.7.0.77 also failed to report the motherboard and CPUs, further none of the 32 x FB-DIMMs were reported when they used to be, yet another regression . HWM reports them, so it can't be down to the CPUID SDK.
  7. No fix for http://forum.corsair.com/forums/showthread.php?p=854759 is rather poor and as I specified before to fix -ve X and fail to fix -ve Y is a major oversight! When I move the CL 4.7.0.77 window to screen 3 as soon as I release the mouse it jumps back to screen two .
  8. Again rather the DRAM CL4 should display the RAM type, DDR4/DDR3/etc. and it's also silly to display 16.0 as the latency and the .0 should not be there except for DDR1. The number of channels and operating mode should also be displayed, Single/Dual/Triple/Quad and Dual Xeon system has 8 Memory Buffers/Channels.
  9. Yet again CL4 should display it's version number as I find many members fail to specify this or state "latest version" when posting.
  10. Yet again I further feel CL4 should use meaningful names rather than the Temp #1 form it currently uses, same for the fan names.
  11. Yet again reporting the same disk temperature twice is silly and causes confusion for some, see the 2nd #2 in http://forum.corsair.com/forums/showthread.php?p=890673
  12. Yet again can control the H110i + H110iGT pump speed using a Custom Curve be added to CL4?
How do I download new firmware into my CL Minis + H100i + H110iGT?
  1. http://forum.corsair.com/forums/showthread.php?p=904256 - I suspect the CL-9011110-WW will replace the CL Mini, does this mean the CL Mini firmware bugs will never be fixed?
Have any of the following firmware bugs been addressed some of which have now been outstanding since 20-Nov-2014? If not on what date are they scheduled to be addressed please?
  1. http://forum.corsair.com/forums/showthread.php?t=134621 - Commander Mini will not control fans based on temp sensors
  2. http://forum.corsair.com/forums/showthread.php?p=757703 - Commander Mini + H100i + H80i fan mode register is not returned correctly.
  3. http://forum.corsair.com/forums/showthread.php?t=137364 - Commander Mini + RGB LEDs - Blinking Issue.
  4. http://forum.corsair.com/forums/showthread.php?p=754023 - 10,000 RPM Fans #1 - Corsair suspect it's a firmware bug of 16-Jan-2015.
  5. http://forum.corsair.com/forums/showthread.php?p=709734 - H100i + H80i incorrect colour if you use zero, use 255,1,1 rather than 255,0,0.
  6. http://forum.corsair.com/forums/showthread.php?p=855427 - H100i + H80i you can't use 1,1,1 rather than 0,0,0 as this is not black.
  7. http://forum.corsair.com/forums/showthread.php?p=837226 - CLCC support for 0% PWM or 0 RPM to stop the fans.
  8. http://forum.corsair.com/forums/showthread.php?p=893630 - H110i + H110iGT Custom mode does not work for the pump.
Here is an itemised list of issues which Corsair failed to respond to or address in a timely manor.
  1. http://forum.corsair.com/forums/showthread.php?p=896054 - CL 4.6.0.86 issues.
  2. http://forum.corsair.com/forums/showthread.php?p=890711 - CL 4.5.0.55 issues
  3. http://forum.corsair.com/forums/showthread.php?p=871675 - CL 4.3.0.154 issues
  4. http://forum.corsair.com/forums/showthread.php?p=864149 - CL 4.2.4.25 issues
  5. http://forum.corsair.com/forums/showthread.php?p=851701 - CL 4.2.3.41 issues
  6. http://forum.corsair.com/forums/showthread.php?p=844974 - CL 4.2.2.27 issues - How do I change the TCP port
  7. http://forum.corsair.com/forums/showthread.php?p=841278 - CL 4.2.1.42 issues
  8. http://forum.corsair.com/forums/showthread.php?p=833499 - CL 4.2.0.162 issues
  9. http://forum.corsair.com/forums/showthread.php?p=833532 - CL asking for a reboot when it should not
  10. http://forum.corsair.com/forums/showthread.php?p=837724 - CL4 using a massive amount of TCP transfers
  11. http://forum.corsair.com/forums/showthread.php?p=833695 - Silly driver package name
  12. http://forum.corsair.com/forums/showthread.php?p=833699 - Issues with > 32 CPUs
  13. http://forum.corsair.com/forums/showthread.php?p=834459 - CL4 does not support CSMI RAID
  14. http://forum.corsair.com/forums/showthread.php?p=836506 - CL4 does not support EC Sensors
  15. http://forum.corsair.com/forums/showthread.php?p=837364 - No support for the original Commander.
  16. http://forum.corsair.com/forums/showthread.php?p=845182 - BSOD #1 caused by Corsair supplied AXi PSU/Asetek Cooler kernel mode driver
  17. http://forum.corsair.com/forums/showthread.php?p=898187 - BSOD #2 caused by Corsair supplied AXi PSU/Asetek Cooler kernel mode driver
  18. http://forum.corsair.com/forums/showthread.php?p=896126 - BSOD #3 caused by CL 4.6.0.86 (CPUID SDK) on W10 RS2 Build 15063.
  19. http://forum.corsair.com/forums/showthread.php?p=845092 - 10,000 RPM Fans #2 - no reply
  20. http://forum.corsair.com/forums/showthread.php?p=853869 - 10,000 RPM Fans #3 - no reply
  21. http://forum.corsair.com/forums/showthread.php?p=854759 - To fix -ve X and fail to fix -ve Y is silly
  22. http://forum.corsair.com/forums/showthread.php?p=839550 - H100iV2 and H100iGTX have different firmware
  23. http://forum.corsair.com/forums/showthread.php?p=850509 - CL4 causing high DPC latencies.
  24. http://forum.corsair.com/forums/showthread.php?p=864164 - CL4 causing high DPC latencies after Corsair claim to have fixed it.
  25. http://forum.corsair.com/forums/showthread.php?p=837228 - CLCC support for 0% PWM or 0 RPM to stop the fans.
  26. http://forum.corsair.com/forums/showthread.php?p=881930 - AMD GPU fan speed and temperature information not reported.
  27. http://forum.corsair.com/forums/showthread.php?p=896497 - previous releases can't be downloaded .
Note that some of the entries itemise up to 52 issues and I expect I reported other issues I could add to the list.

I feel Corsair should be posting the following as only the latest release is available via the support downloads and some members wish to revert to old versions
Quote:





Attached Images
File Type: png LNP 0.3.72 Firmware Update stuck @ 35%.png (8.7 KB, 6700 views)
File Type: png REX.png (177.7 KB, 6635 views)
File Type: png RXD.png (222.2 KB, 6367 views)
File Type: png REG.png (205.7 KB, 6184 views)

Last edited by red-ray; 07-01-2017 at 09:15 AM. Reason: More issues + PCH/ICH SMBus locking broken !!!!! 1.1.6.7 CPUID SDK fixed things