View Single Post
  #18  
Old 10-02-2017, 04:27 PM
Hoffax Hoffax is offline
Registered User
 
Join Date: Oct 2015
Posts: 14
POST ID # = 921920
Hoffax Reputation: 10
Default

I was playing a game when my headset started beeping that the battery was low, so i plugged in the charger, and then the headset started beeping rapidly at an even pace and wouldnt stop beeping for over a solid minute, so i unplugged the charging cable and the beeping stopped. So i tried plugging in the cable once again and the same thing happened, only this time the headset just stopped working and was no longer connected to the dongler or emitting any lights. I tried plugging the headset into another wallsocket, but no light was emitting whatsoever, And also the left earphone was super hot and smelled burnt. I updated the dongler firmware and tried pairing it, but the headset remains dead and not light is working. when i plug the headset into the computer via a micro usb to USB cable, it showed up as a "Avnera" device.

What do i do?
Reply With Quote